General discussion

Locked

5+4 zip codes in mail merge

By p_cheatum ·
I have a user who has an address listing in Excel which includes both the standard 5 digit zip code and the expanded 5+4 zip code. She wants to use this data list to print mailing labels. After she runs the Mail Merge Wizard in Word (2002) and selects her data for printing the labels, the zip codes with the 5+4 format appear as 0?s. We tried removing the dash in the longer digits and changing the format in the Excel datasheet to the 5+4 format but in the merge, it still shows 0?s for those zips.



Neither of us are expert Excel users and I have been unable to find an answer to this. She ended up this time removing the +4 digits but in the future, she would like to be able to use the entire zip code.



Any help would be greatly appreciated!!



Thank you.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by HAL 9000 Moderator In reply to 5+4 zip codes in mail mer ...

The problem isn't so much in Excel but in the way that the Mail Merge Wizard was run or the spacing allowed in the fields in the Word Doc.

Since you are getting the right number of charters I would be looking at the way that the Mail Merge has been setup as it is deleting the extended numbers or at the very least not importing them but is seeing that there should be something there and inserting 0's.

Have you tried using the Label Printing option from Excel to see if you get the correct results from there?

Since these are only labels you should not need to go into word but just use the Label Printing option from Excel and define how you want the labels to appear and the size of the labels this you'll have to input manually and then the program should do the rest.

Col

Collapse -

Found the Answer

by leslie In reply to 5+4 zip codes in mail mer ...

I had this problem too and was really stumped. Its not the same problem as the leading zero's.
Here's what you do:
In the Word Document on the Mail Merge Toolbar select "Mail Merge Recipients". Its the spreadsheet with a pencil icon. You will see a list from your spreadsheet. Look at the postal code column. When I looked at it, it was all zero's. Select the drop down box and change from Blanks to Non-Blanks. Now your postal codes will display properly. Good Luck!

Collapse -

Solution--Open Conversion

by kristin184 In reply to Found the Answer

Hello,

Unfortunately, changing your recipients to Non-Blanks will remove the zip+4 recipients. To truly include all recipients with all zip codes showing up in the mail merge, do the following:

In Word, go to Tools>Options>General tab and make sure "Confirm conversion at open" is checked.

Once it is checked, when you import a list into your mail merge, Word will ask you if you how you want to import. Choose the DDE option, which will allow you to get all zip codes, 5+4 included.

Note: the DDE option will only import the primary (first) worksheet of your excel so make sure your mail list is in the first excel tab.

Collapse -

Zeros in Zip+Four Mail Merge

by marketing In reply to 5+4 zip codes in mail mer ...

Another answer that worked for me is to format your Zip Code column in Excel to "Text" instead of numbers. I did it, and then all the zips and zip+4s worked perfectly in my mail merge.

Back to Software Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums