Question

Locked

A device stops working when a driver for another device is installed

By douha ·
Hi all,

I have a situation that I created for myself and don't know how to recover from.

I have an Acer Aspire 5570z laptop that I have downgraded to Windows XP.

Due to that fact that this machine is configured by Acer to be a Vista machine, I wasn't able to find all of the device drivers on Acer's web site for this machine running XP Pro. I ran a device driver update program and found a newer driver for the machines card reader.

I installed this driver and the touchpad stopped working.

I found that if I attached an external mouse, I can use it without a problem. In an effort to recover the functionality of my touchpad, I reinstalled the driver for the touchpad. Nothing happened. I installed an older driver for the card reader thinking that it might help. Nope. I look for other drivers for both the touchpad and the card reader. Nothing I try brings back functionality to the touchpad.

I finally decided to reinstall windows xp pro to see if that would help. In the process of doing this, I also deleted the drive partition, recreated it, formatted it, and installed windows xp.

Still no functionality from the touchpad.

The way I see it now, I have two more options. One is to have the bios reflashed on the machine. My thinking there is that the new card reader driver that I had installed has done something to the bios. The other option would be to replace the touchpad in the laptop. My supposition here is that something about the card reader driver has damaged the touchpad hardware.

Before I take these drastic steps, I thought I would ask for advice from those who know more about these types of things than I do.

Thanks for taking the time to read this epistle.

Doug

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

In the BIOS config

by w2ktechman In reply to A device stops working wh ...

is the touchpad disabled?

Collapse -

Thanks for the response

by douha In reply to In the BIOS config

How do I find the bios settings?

Collapse -

For future reference

by seanferd In reply to A device stops working wh ...

Roll back the drivers, rather than installing old on top of new. This may save some headaches.

Flashing the BIOS *may* have helped with the original issue, but it would not be changed by installing/uninstalling/formatting anything.

As w2ktechman says, check the *settings* in BIOS to see if they have changed.

Collapse -

Thank you

by douha In reply to For future reference

Are the bios settings the same as the Device Manager?

Collapse -

Well neither of your options is likely

by OH Smeg In reply to A device stops working wh ...

Start off with checking the BIOS and seeing if the Touchpad has been disabled and the IRQ Addressing is anything but the Default. If either of these have been changed return then to the Factory Recommendations.

It's possible here that either the Touchpad has been disabled or the IRQ Addressing has been altered to produce a Conflict which stops something from working.

As for installing XP to a computer without a Full Driver Support from it's maker you need to find what they do have if anything at all and use that. If they don't have a full set of Drivers available use this Application Unknown Device Identifier

http://www.fileheap.com/software-unknown-device-identifier-download-34861.html

Then do a search for the required XP Driver that is missing. I do not recommend using software to locate drivers because this isn't the beast way to proceed and can introduce Infections that are extremely hard to remove, quite often a simple Format will not be sufficient to kill off any nasty infections. You need a Utility like Boot & Nuke available here that writes zero's to every sector of the HDD unlike a Format which only writes to every third sector leaving 2/3 of the HDD untouched. The Fast Format Option does even less.

http://www.dban.org/

Col

Collapse -

Where are the bios settings?

by douha In reply to Well neither of your opti ...

Thank you everybody for your responses.

You all talked about checking the bios settings for the touchpad. I would be glad to do that if I knew how.

Looking in the device manager for windows I can see that the touchpad is enabled. The driver status for the device shows that everything is normal. The IRQ showed that there are no conflicts for the device.

Thanks for your continued help,

Doug

Collapse -

Bios is that bit that works before Windows stats to load

by OH Smeg In reply to Where are the bios settin ...

So you will see something like a System Makers Logo like Dell, HP or so on or if it is a White Box you may see a M'Board Makers Logo or white writing on a Black Screen.

This comes up before Windows starts to load just after you push the On Button and will have directions for entering BIOS on that screen. Something like Press Delete to Enter Setup or maybe F2 or F12 depending on who makes the thing. You need to save any changes that you made when you go to exit the BIOS and you will be prompted to do this by every BIOS.

The worst that you can do here is mess up completely and to recover from that all you need do is select the option to set to defaults and then save the changes on exiting the BIOS to return to a working system.

Col

Collapse -

ok, I see

by dharding In reply to Bios is that bit that wor ...

Thanks again.

I have checked the bios settings on this machine. There isn't anything there that I can redily identify as having to do with the touchpad.

Collapse -

Then there is likely a software conflict

by The Scummy One In reply to ok, I see

if there are no conflicting IRQ's, and there is no BIOS setting to disable the touchpad when another device is plugged in, then there is another conflict. Maybe a shared file is the issue.
try re-installing the drivers for the touchpad, maybe look for an update to it.
Or, after plugging in the mouse, try a driver rollback on the touchpad.

Back to Hardware Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums