General discussion

Locked

A File Type Association problem

By laswack ·
Trying to open the file Test.xls by double clicking in Explorer

Double click on an .xls or .xlb file in My Documents directory and receive the following message:

C:\My.xls could not be found. Check the spelling of the file name and verify the location is correct.

If you are trying to open the file from your list of most recently used files on the File menu, make sure that
the file has not been renamed, moved or deleted.

Then the next error is:

'Documents\test.xls could not be found. Check the spelling of the file name and verify the location is correct.

If you are trying to open the file from your list of most recently used files on the File menu, make sure that
the file has not been renamed, moved or deleted.

Thenthe file Test.xls opens

I have verified the Folder Options File Types in Explorer for Worksheets and confirmed with another machine that is
working correctly

I have also removed the Open option, re-started the computer and created it new - problem remains !

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

A File Type Association problem

by savatovic In reply to A File Type Association p ...

Try to check for virus.
Also, go to command prompt.

CD "My Documents"
dir My.*

In the listing check that you have My.xls and not something like My.xls.shs or My.xls.vbs.

If your system is virus free, try to reinstall MS Office.

Collapse -

A File Type Association problem

by laswack In reply to A File Type Association p ...

Poster rated this answer

Collapse -

A File Type Association problem

by laswack In reply to A File Type Association p ...

No there is not a virus, and a re-install is a no brainer. I suspect that a component of Office 2000 was installed at one time and this is Excel 97 that has something to do with it

Collapse -

A File Type Association problem

by ChuckAB In reply to A File Type Association p ...

This appears to be a "Long Filename" problem. I've had to fix this many times.
Open "Explorer".
Click on View | Options
Click on the "File Types" tab.
Find the .xls extension ("Microsoft Excel Workbook" or some such)
Click the EDIT button.
Inthe lower window you will see several options. Click ONCE on "Open" (it should be in BOLD).
Click the "Edit" button beneath.
You should see something like:
"C:\Program Files\ [path] \EXCEL.EXE" /e
Below, you may see in the "DDE Message" block: [open(%1)]. If so, change it so the '%1' is in quotes - like this:
[open("%1")]
If the "Use DDE" block is NOT checked, look at the end of the "Application used ..." block for the '%1'. If it is NOT in quotes, PUT IT in quotes like this: "%1". DON'T put it inside the first set of quotes. Make sure it's in its OWN set of quotes - like this:
"C:\Program Files\ [path] \EXCEL.EXE" "%1"
This is proof that the Windows OS is still deeply rooted in DOS. Even though it supports long file names, it looks at the file system in the 8.3 format first (spaces are illegal). If you want it to look at the LONG file name, you have to put the reference (in this case in a replaceable variable) in quotes. (Hmmm... Reminds me of batch files!)

Good Luck

Collapse -

A File Type Association problem

by laswack In reply to A File Type Association p ...

Poster rated this answer

Collapse -

A File Type Association problem

by laswack In reply to A File Type Association p ...

This question was closed by the author

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums