General discussion

Locked

access and permissions problem

By cfordjour ·
I have recently setup up a small network of 5 machines all using xp professional. I have given it a workgroup name and have no problems sharing files and folders between all machines. However one of the machines is to be used for accounts and the machine i'll be using needs to access the accounts but all the rest should not be allowed to access the accounts folder. So far i have created an user account on the accounts machine with the same user name and password as mine. Then i went to the sharing and security tab for the folder and gave the user account full control access permission, however this does not seem to work. When i remove the everyone access control I am unable to access the accounts from my machine all i get is the access denied error. Any help with this issue would be much appreciated.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by cmiller5400 In reply to access and permissions pr ...

Make sure that simple file sharing is off. In Windows Explorer, Tools, Folder Options, View, Uncheck Simple file sharing near the bottom. Make sure that NTFS permissions are set as well as share permissions and remember that share permissions are most restrictive. e.g. readonly to share means readonly to every file under the share regardless of NTFS permissions on the files.

Collapse -

by cfordjour In reply to

Thank you for your reply. Unfortunately, i had already tried that to no avail. I have turned off simple file sharing, that is how i was able to access the sharing and security tab. I have added my user account to the sharing and security permisions with full control, however i am still unable to access the accounts machine. All i'm trying to do is allow my machine to access the accounts machine without allowing the other 4 machines on the network access to the accounts machine.

Collapse -

by curlergirl In reply to access and permissions pr ...

Did you reboot both machines after making the changes? NTFS permissions are a bit tricky and usually require logging off and back on to enable/disable a particular user's access permissions.

Also, you need to check the share permissions as well as the access permissions on the folders (or disk-level) above the shared folder. In NTFS file sharing, there are share permissions as well as folder-level security settings. On the Sharing tab of the folder, click the Permissions button to see the sharing permissions. Since the default share permissions in XP are Everyone/Read Only, that may be the problem - you need to remove the Everyone permissions and add your user ID with Full access. Also, check the security settings on the folders and/or disks above the shared folder - if you don't have at least read permissions to the levels above the folder, you will not be able to access it.

Hope this helps!

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums