Question

Locked

Access Denied during a device installation

By herk.papadakis ·
Hello,

I am getting the following error when i try to update a device driver in the "Device Manager":

"Cannot Install this hardware. There was a problem installing this hardware:

Network Controller

An error occured during the installation of the device

Access is denied"

It appears that i do not have access to update any device drivers in the system.

It is a laptop with XPSP2 and i am login in as the admin.

Thanks in advance.

Herk.

This conversation is currently closed to new comments.

17 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Files in use....

by ThumbsUp2 In reply to Access Denied during a de ...

The system can not update a device if it's files are in use. Try disabling the network controler in device manager, reboot, then try updating the drivers before you enable the device.

Collapse -

Same issue

by herk.papadakis In reply to Files in use....

I tried your recomendation even before i posted the question. It does not work. I think there is a registry entry that i need to modify. I never had before any trouble updating a driver even if the device was in use.

I can see the devices okay. I can enable or disable without a problem. But the minute i try to update any driver for any device, i receive the "access denied" error. That's why i think a registry permission is the problem. I just don't know where.

Collapse -

'chown' or 'chmod'

by Absolutely In reply to Same issue

Oh, sorry, I forgot, you're using a property ownership obfuscation algorithm, not an operating system.

TS

What driver are you trying to update, anyway?

Collapse -

RE: Access Denied during a device installation

by Jacky Howe In reply to Access Denied during a de ...

Not sure if it will work but it's worth a try.
Go to Start Run in the Open box type in secpol.msc
Navigate to Local Policies and Security Options.
The 'Network Access: Sharing and security model for local accounts'
Try setting it to Classic.

Collapse -

Same as before

by herk.papadakis In reply to RE: Access Denied during ...

Here is an objervation. If i delete the device from the device manager and then try to re-install, then during the driver installation, it's when i get the error. If i just try to update a driver without first deleting the device, then it says that there is no better driver and it stops without any errors. It is just when it tries to load a deleted device or a new found device, the error occurs.

Collapse -

Re: device installation?

What device are you trying to load/take off?
If you need to remove any drivers to a device to make it run/load more stable, then you will need to do this: IMPORTANT:::LEASE MAKE SURE YOU DO A FULL BACKUP OF YOUR COMPUTER BEFORE YOU DO THIS.
1) start > run type in "regedit" and then press enter.
2) In the "edit section > find" box type in the program or driver that you are trying to delete or get rid of, you will see "name, type, data. Up in the top right under "name" (default) delete these file(s) ONLY. Keep on doing this until the registary can no longer find the program or device in your computer. PLEASE be carefull not to delete anything other then the program or driver that you need to get rid of.
3)Reboot.

Collapse -

I have done that too...

by herk.papadakis In reply to Re: device installation?

it seems like everything is working okay using the driver installation wizard until it gets to the very last step. The same thing happens when I uninstall a device (any device, like video or net adapter or mice.... The "Found new hardware" wizard starts, it finds the device, then proceeds with the installation of the driver and very soon it comes back with the error "Cannot install this hardware, an error occured during the installation of the device -- ACCESS IS DENIED".

If i attempt to just update a driver it works just fine. But if i delete the device then it's like i do not have the right to install the device. It is very strange.

Collapse -

User Accounts

by Absolutely In reply to Access Denied during a de ...

Are there any other Administrator Accounts? Try logging in as one of those. I think I vaguely recall that there can be differences in the levels of Administrators -- but don't quote me.

Collapse -

User Accounts

by herk.papadakis In reply to User Accounts

Yes, there are other administrator accounts and yes i have used them all. The result is the same.

Collapse -

Yes, but have you tried logging in as....

by ThumbsUp2 In reply to User Accounts

THE Administrator, not just a user account with administrator privileges?

THE main Administrator account can be reached at login. At this time, either you have a dialog screen where you can type in user names, or you have the welcome screen where you click/select the user you want to login as. If you have the welcome screen showing where you can not type a user name, press ctrl+alt+del twice to bring up the same dialog box previously mentioned where you can type the word "Administrator" (without the quotes) as the user name, then provide the Administrator password.

If this device driver issue still happens when you're logged in as "the BIG boss", you've got more problems than you realize. If that account can't install devices, nothing can.

Back to Software Forum
17 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums