Access Denied on a usb drive

By mr_t_wright ·
Ok so my when I put my usb drive into my computer yesterday it told me "access denied" when I tried to open it. I have owner ship of it, it allows me to access it, if I right click and use "explore" but I cant save to it. And the day before I didnt have this problem...

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Plain flash drive, or does it have its own software?

by seanferd In reply to Access Denied on a usb d ...

You may have set it to 'read-only' somewhere.

Collapse -

yes, plain flash drive

by mr_t_wright In reply to Plain flash drive, or doe ...

It wasn't set to read only. I am thinking the drive letter changed, but even so, it wouldn't make scene for none of the flash drives that i put it to work. I put two in, and they both say "access denied"

Collapse -

Let us know if this has been helpful

by Jacky Howe In reply to Access Denied on a usb d ...

Open a Command Prompt by pressing the WinKey + r and then typing <b>cmd</b> in the run box. At the command prompt type the (drive letter): and press Enter.

drive letter is the drive letter that you are connecting to.

type dir /ah and press Enter.

This will display a list of the Hidden files on the Drive. Check whether the following file is there Autorun.inf and also look for suspicious .exe files.

If the file is there

type notepad autorun.inf and press Enter.

Save the file to another location with an extension .txt as this will contain the executable file that is being invoked.

Type attrib -h -r -s (drive letter)autorun.inf and press Enter.

Type del (drive letter)autorun.inf

To remove the files from the Registry and the Locations that they are invoked from follow these instructions.

Tip! The executable file will be named in the file that you previously saved with Notepad.

Press the WinKey + r and type in <b>msconfig</b> and press Enter. Click on the startup Tab.

Check the list to find the file that you are looking for, expand the <u>Location</u> column to see where it is loading from in the registry.

Press the WinKey + r and type in <b>regedt32</b> and click OK. Browse to the key listed in the <u>Location</u> column for Msconfig.

Delete the key on the right hand side only, that specifically matches that startup file.

Note the <b>Command</b> folder in msconfig. Browse to the folder, and delete the .exe file.


The Startup TAB of Msconfig will show you the directory where pop.exe loads from:

<b>Command</b> c:\Windows\system32\pop.exe


<u>Location</u> will guide you to it's location in the Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

With the registry editor open find the Run key in the left window. On the right hand pane you'll see each file that is in the Run key, pop.exe will be there. Right click and Delete the entry for pop.exe.

Browse to the c:\Windows\system32 folder, and select the pop.exe file, hold down the Shift Key and press the Del Key.

Repeat these steps for each item that you want to remove.

Collapse -

I have the same problem

by mjabadilla07 In reply to Let us know if this has b ...

hi, I got the same problem and got a question cant i just directly select on the file i want to erase and just Shift + del it right away? bec. some of my friends tells me its the easiest way but i have my doubts I'd really appreciate if you clear these things thats bugging my mind right now

tc God bless

Collapse -

You should remove

by Jacky Howe In reply to I have the same problem

the file attributes before deleting the file. That's why it is suggested to use attrib. Also check the root of all of your drive letters for the autorun.

Collapse -

No malicious files,

by mr_t_wright In reply to Let us know if this has b ...

No malicious files, the autorun is there. I am still having this annoying problem

Collapse -

What are the contents of the

by Jacky Howe In reply to No malicious files,

autorun file. What is it opening?

* has the drive got a switch to enable write protection.

EdiT: * afterthought

Collapse -

IT deparment blocked the access of pendrive

by vadrenaline In reply to Access Denied on a usb d ...

Hello dear sir,

I am viren, my office uses the LAN with cyberoam client and all the computers run a win xp service pack 2, quick heal security (which is password protected and password is not known to me)

problem: the IT department of the office has disabled all the pendrives in the office, that is, when pendrive is inserted it loads its drives and in my computer f removable disc appears, on clicking it "access is denied" appears.

I have tried following methods without any use:

1. installing drivers fro the pendrive
2. tweaking the registery values of usbstor -->start , it was already set to 3.
3. creating registery entry for write protect
4. device manager usb storage is already enabled
5. tried to access it through command prompt and start-->run, same message "access is denied"

the IT department has recently block the use of pendrive and there are few secured computers where they are re-opened on the special permission of CEO.

can you help...

Collapse -

Reponse To Answer

by PurpleSkys In reply to IT deparment blocked the ...

your IT department put those security features there for a reason; we can not help you bypass their security

Related Discussions

Related Forums