Question

Locked

access denied to owner on XP SP3

By ianoz ·
I recently reinstalled Windows XP Pro on one of my computers and added 2 external harddrives that I used on a separate machine (now disposed).

For the migration I copied all my personal files to 2 external HDDs.

Now I've reinstalled XP I'm getting "Access Denied" when I attempt to copy some files from the external back to the C drive. It appears to be random- not specific to folders or filetypes.

I have followed everything I've found on the web to no avail. Tried so far: 1) taken ownership of all files and folders, both as admin group and as specific user name, 2) logging on as Administrator as well as administrator user and 3) started all services in service manager but none of these have solved the problem.

I believe its a permission glitch as it happens with exactly the same files on both drives.

Both disks check out ok on chkdsk. The previous computer was running XP SP2 username Ian Smith, the new one is running XP SP3, username Ian.

I've also hooked up the drive to a machine running Ubuntu- it gives a "permission denied" for exactly the same files so now I'm really confused.

Any help would be very much appreciated- I'm starting to get worried about the data.

Thanks,
Ian

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This may not help

by nepenthe0 In reply to access denied to owner on ...

There is a Microsoft Knowledge Base bulletin that you have probably already reviewed:

http://support.microsoft.com/kb/308421

which discusses how to take ownership of a file or folder in Windows XP

A similar situation arose a few weeks ago, and I think it was Boxfiddler who posted a resource page on Kellys Korner:

http://www.kellys-korner-xp.com/xp_d.htm

which discusses the issue of Permission denied when trying to delete folders/files.

Rick/Portland, OR

Collapse -

thanks but didn't work

by ianoz In reply to This may not help

I've tried both of them.

It's weird- says I (or Administrators) are the owner with Full Control but permission denied to copy the files.

Exes can be run successfully so I think it has got be permissions.

I saw another thing on kellys-corner. Used regedit to give everyone full control of the LOCAL_MACHINE/SYSTEM/CurrentControlSet/Enum/USBSTOR/<<drive name>> but that didn't work either- permissions still denied.

Collapse -

Something else to review

by nepenthe0 In reply to access denied to owner on ...

Microsoft has posted a registry edit addressing access denied issues concerning XP3 installation:

http://support.microsoft.com/kb/949377

That does not specifically address your issue of access denied after successful XP3 installation, but it might point you in the right direction.

Rick/Portland, OR

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums