Access denied? Windows cannot access specified devide, path or file?

By johnjeremi ·
I have a problem that has developed on my user account. When I try to open any EXE file or MDB file on a network drive I get the following message.

Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.

I can open other file types without a problem - even files in the same folders as the problem files.

I've double checked the permissions and I have full control on all the files in the folder.

I've run a full virus scan on the machine and there are no viruses (the pattern file and engine are up-to-date).

I've scanned the machine with the latest versions of Windows Defender, SpyBot and AdAware.

I've checked the problem from another machine and it follows the user account.

If I copy the file to a local (C:) folder I can run it without any problems.

Basically this is the same problem as other people have had before. I looked this windows message up and read extensively on it. But everyone seems to fix it by doing "unblocking" of a particular application or copying all the files into a newly created account.

My problem is not that I downloaded anything that caused the computer to mess up or that another program such as an antivirus is causing the issue. Instead, my computer was running very low on disk space. Before I could do a back up to an external drive to empty out the c:drive in the computer, the machine kept giving me virtual memory too low messages. Then, when there was too low space, something weird happened: I tried loggin into my windows account (which has admin privileges) like I always do, but the computer gave me a message saying that there was going to be limited functionality because of too low virtual memory or somethign along those lines. What windows actually did,was it created a ghost mirror account with the exact name as my other account, but stripped of many of the customized feautes that I assume require disk space to show up. For example, all the templates, the screeensaver, etc, are generic as if I had logged in for the first time. From this new account that has the same name as the old one, I can access the files of my other account. But not many of the things that were there. One exampkle of many applications that i use is skype. I keep pictures of my children from some of the webcasts in my user profile. When I tried skyping for the first time from this new account, it basically treated skype as a brand new application. Everything that I had on it is not there anymore. But everything should still be in the old account. When I go to user accounts, I see both the old and new accounts, but for some reason when I start windows and log in, it automatically logs me onto the new account.

I have resolved the disk space issue and I figured that it might solve the issue and allow me to log back into my previous account, but it still logs me as the new account. And now, not only that, but I get that message saying access is denied and none of the appkications can be started. It will not let me do unblock by right clicking each application. I restarted on safe mode and it lets me do the unblocking from safe mode. But i cannot do unblocking when i log onto the account. I don't want to delete this new account for fear that it will delete everything I had from my old one, but I don't know how to go about this.

I tried system restore (cant because there is no point of restore since there were memory issues and SR does not create checkpoints when memory is too low), I also tried the unblocking thing, restarting safe mode, seeing if i can get functionality back by doing some of the things that others have done regarding this same issue but nothign seems to work here. I'm just about ready to give up.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

sounds like the profile is corrupt

by markp24 In reply to Access denied? Windows ca ...


sounds like the admin profile is corrupt,

make sure your have at lease 1/3 of your hard drive free (may be more than you need but goo the be safe)
boot into a command prompt or boot from a live linux disk
browse to the c: drive then users forlder
rename the admin account's folder your haveing issues with and reboot
when you log in it will recreate the profile folder for you, then you can copy the files back into the new admin accoutns folder and see if they work.

Collapse -

Reponse To Answer

by johnjeremi In reply to sounds like the profile i ...

Hey thanks for the response.

So how do I go about all this? I don't know how to navigate though anything linux related, and I don't know how to do a boot into a command prompt.
ALso, how do I copy the files into this renamed admin account? Is there a step by step guide to what I'm supposed to be doing here?

I'm lost.

Thanks so much in advance for your help!

Collapse -

Reponse To Answer

by markp24 In reply to sounds like the profile i ...

Log off the user account that you want to change the name of.
NOTE: If you do not have another administrator account to use, then create a new administrator account first, then log off. When finished with the tutorial, you can delete this newly created account.

Log on to an administrator account that is not the user account that you want to change the name of.

Open Windows Explorer, navigate to c:\documents and setting or for vista/win7 "C:\Users", open the folder, right click on the user profile folder (ex: Old Name) that you want to change the name of, and click on Rename to somthing else "ie old "username"". (see screenshot below)

click on Continue and Yes (UAC) to approve renaming the user folder, if you asked

then reboot, login with the original name of the corrupted profile
a new profile will be created

then once in there, Open Windows Explorer, navigate to c:\documents and setting or for vista/win7 "C:\Users", open the folder, open the old folder, then copy the documents and folder out of the old account , broswe to the new account and past them there.

Collapse -

no problem

by markp24 In reply to Access denied? Windows ca ...


let me see what i can dig up or put together for you, i may need a bit of time before i post it.
but check in again (thinking tomorrow afternoon)

Related Discussions

Related Forums