Question

Locked

Accessing Windows 2003 shares via Mac OS X

By stein_brian ·
Hello,

In our Windows 2003 domain, we have 2 Mac's left that are used with no issues. It's very simple, they get their email via OWA, and I was able to successfully use SMB to connect them to their home drive on a Windows 2003 server. All has worked for months. All of a sudden this morning, both users cannot access their home drives. If I click on 'Go -> Connect to Server' and try to connect to the server/share I get one of the following errors:
-'The finder cannot complete the operation because data in "SMB://server name/share name" could not be read or written.'
- If i broswe the network and click on the server it tells me 'the alias could not be opened.'

Any other Windows server will prompt me with the SMB/CIFS File System Authentication box where I can login with the Windows credentials. This server does not, though it has in the past because that's how I got it working. Is there a way to force the pop-up box to come up? Is the Mac somehow cacheing the credentials for this connection to this server since I have accessed it in the past? Any thoughts would be really appreciated!

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

this is MACs on the network or remote users using a MAC?

by CG IT In reply to Accessing Windows 2003 sh ...
Collapse -

This Mac is on the network

by stein_brian In reply to this is MACs on the netwo ...

They're connected to the domain or anything but are on the network and have an IP Address on the correct subnet. Internet access works, and like I said, they can even use SMB to get to other servers. It's just this one server that they always use no longer works and I cannot get the authentication screen to pop-up. I even sometimes get an error saying it's the wrong user name or password though I never typed anything in b/c I never was presented the opportunity.

Collapse -

they are or are not connected to the domain?

by CG IT In reply to This Mac is on the networ ...

If they are not connected (joined) to the domain, try to access resources on the domain, they will need domain credentials. If those credentials change, such as required password changes, then credentials will have to be re-entered.

If you are 100% sure they are on the same subnet, you should get a request for credentials using TCP/IP on the MAC computer. Check to make sure your not using IPX.

Collapse -

re: they are or are not connected to the domain?

by stein_brian In reply to they are or are not conne ...

Sorry, noticed my typo on the last post. They're not joined to the domain, but are on the network. The problem is not with the TCp/IP settings, amd they are using TCP/IP. The problem right now is just that this one particular server will not prompt for the credentials. At one point it did, in fact once I put in their credentials a few months ago it held and they had no issues accessing the folder they needed off this server. However, now they can't access the folder and I can't find a way to force the authentication box to pop back up. The box does come up for any other server that has not been previously accessed from this mac.

Collapse -

ah last question are they accessing mapped drives?

by CG IT In reply to re: they are or are not c ...

typically, non domain users and computer will always be prompted for credentials every time they try to access resources. period.

When you say that you put in credentials and they held, does that mean users did not have to enter credentials after that? if so then I would say cached credentials is keeping the users from accessing the resource.

see this MS KB article on cached credentials.
http://support.microsoft.com/kb/**3485

Collapse -

re: ah last question are they accessing mapped drives?

by stein_brian In reply to ah last question are the ...

Well technically from the Mac point of view it'd not a mapped drive, though it is for the Windows users. What I mean by they put in their credentials and it held is that a few months ago for this Mac user on their Mac, I went to Connect to Server, put in the server name, then got prompted for the credentials, after putting in the users credentials I was presented with the applicable shares on the Windows server, and when I selected the correct share, the folder showed up on the Mac and then it held meaning it worked fine everyday (until last week).

Once the user reported that the folder was not working last week, i tried doing the same steps i just mentioned but instead of getting prompted for the credentials, I get the errors previously discussed. If I do the same steps but point to any other Windows server I get prompted for the credentials. It's almost like the Macintosh is caching it or something.

Collapse -

Just saw this post

by br1er In reply to re: ah last question are ...

Hi might be a little too late since I see the last post was in July but might help others out. Sounds like the user name and password are saved in Keychain (Mac Utility to save login info). So in the Utilities folder, double click Keychain and look for the entry to the file server's login credentials. Delete this entry and next time you connect to the server you should get prompted. Hope this helps

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums