Acer Aspire 5570z DDR 667 Compatibility Issues...

By m4c4br3 ·
I recently purchased a 2 GB RAM upgrade kit (2x1) for my old Acer Aspire 5570z laptop. The RAM that is currently installed is exactly the same in every way to the RAM I purchased, except for just three things: the new RAM sticks are each 1 GB (2x1 2 GB kit) as opposed to the old ones, which are both 512 MB sticks; the CL on the new sticks are 4, compared to the old ones which are CL 5; the new sticks are DDR2 667 (PC2 5300), and the old ones are DDR2 533 (PC2 4200). I installed the RAM earlier today and the usual signs that the RAM was not compatible (common BSODs, computer becoming unresponsive, random system shutdowns/reboots, etc.). I reinstalled the old RAM sticks and as expected, the problems disappeared. I did some research to double check the compatibility, and the only thing I can see possibly being an issue is the speed. The old RAM is DDR2 533 and the new RAM is DDR2 667. Most sources I checked state that the Aspire 5570z is capable of utilizing DDR 667 (PC2 5300) RAM. Surprisingly the Acer website does not specify whether it can use DDR2 667 or not. Regardless of whether it does support it or not, it is my understanding that the RAM should automatically under clock to an acceptable speed. Could this be an issue with dual channel not under clocking properly? Did I receive bad RAM? Or is there something I am missing entirely?

Here are some links that might be useful:

Data for the new RAM (PDF):

Acer Aspire 5570z Specs:


This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Did you use an online system scanner to check RAM?...

by OldER Mycroft In reply to Acer Aspire 5570z DDR 667 ...

Put the old 2x512MB back in, boot up and try this site:

Download the little bit of code, run it, then let Crucial scan your system. It'll come up with all the available RAM configurations that are compatible with your laptop motherboard's chipset, showing the maximum RAM possible too. :)

As to your comment of "Surprisingly the Acer website does not specify whether it can use DDR2 667 or not."

It shouldn't be surprising at all, if it CAN'T use it. Acer have stated it runs with DDR2 553MHz RAM, which matches the System Bus Speed of 553MHz.

You wouldn't buy a program that stated Windows XP-compatible on the box if you were running Windows Vista, on the assumption that because it didn't say 'NOT COMPATIBLE WITH WINDOWS VISTA' then it must be Vista-compatible. Would you?

Collapse -

Good point

by m4c4br3 In reply to Did you use an online sys ...

Thanks for the quick reply :)

For whatever reason the crucial scanner will not work. I can see a cmd window open for a brief moment then disappear, and my browser does not launch like it shows in the video. I did enter my laptop information manually, however. All of the RAM that they have shown as being compatible are also DDR2 667.

<b>Edit:</b> I guess I wasn't seeing the .htm file that the scanner was creating. I finally found it and when I opened it, all of the RAM it showed me was DDR2 667. So apparently I should be able to use this RAM perfectly fine, as that is the only difference. Unless the lower CAS latency on the new RAM is what is causing the problems. All of the RAM it tells me is compatible with my system is CL 5, while my new RAM is CL 4. Could this be the problem?

Here's an interesting update on the situation: I ran memtest86 earlier today and found that when I use only one stick of the new RAM, the test passes without error. However, when I run the test with both sticks inserted, I get flooded with errors. In fact, the test stopped functioning altogether and I was forced to power off my laptop. Because memtest86 runs separately from the OS, I was not able to take a screen shot. But I did do the next best thing (short of writing it down - too much info!). So here is the best picture I was able to get of the test results (up until the test stopped functioning).

It got to about 50% before it began showing any errors. I wasn't able to fit in the entire screen without sacrificing clarity, so here's some data that was left off:

1. Total errors: 514
2. All of the errors occurred on test 7 (random number sequence)
3. Type = STD

"It shouldn't be surprising at all, if it CAN'T use it. Acer have stated it runs with DDR2 553MHz RAM, which matches the System Bus Speed of 553MHz."

Good point :) I just hate Acer with a passion, and I had to blame somebody for the RAM not working!

Collapse -

Also after fitting the new RAM

by OH Smeg In reply to Acer Aspire 5570z DDR 667 ...

Did you open the BIOS and make sure that it was actually seeing the newly installed RAM?

If it was did you save the Changes as you exited the BIOS?

If you didn't the computer is attempting to Map 1 GIG tot he new 2 GIG Modules and this could very well be causing the BSOD issues. as the system is falling over with RAM errors.


Collapse -


by m4c4br3 In reply to Also after fitting the ne ...

Thanks for the response. Yes I did this on the first boot up with the new RAM installed. The BIOS was correctly reporting the new RAM. I saved and exited. As the crash is not instantaneous, I was able to check 'My Computer' while logged in to Windows 7. It too was correctly reporting the new RAM.

Collapse -

OK then the other thing is the Density of the RAM

by OH Smeg In reply to Check

You have High & Low Density RAM and quite often if you fit High Density RAM to a M'Board that can only use Low Density RAM you will get issues like this.

Instead of the Link that OM posted above try the Corsair Site and see which type of RAM they recommend for this system


Collapse -

Agree With RAM Density

by TheChas In reply to Acer Aspire 5570z DDR 667 ...

I fully agree with Oh Smeg that RAM density is most apt to be your problem.

The manual that I have for my 5570Z does state that it can use DDR677 RAM. However, it also states that you can install up to 4GB of RAM which I know is not correct.

I have 2GB of DDR533 in mine that I bought just after I bought the Acer.

And, that is the key. Do not wait to upgrade RAM. Install the maximum amount of RAM when the system is new. That way, the memory manufactures do not have time to change RAM timing or density such that new RAM will not work with your old hardware.


Back to Web Development Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums