Question

Locked

Acer Aspire AM1641 has no output

By Bronn ·
I got this Acer with 2GB ram, 360 GB HD and a NVIDIA GeForce 7050. It powers on but has no video, no beeps while powering up, no output at all. The fans come on, the dvd powers up but that's it. I think the motherboard is shot but I don't know how to varify it. Does anyone have any ideas that may help??? Thanks.

This conversation is currently closed to new comments.

13 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

have you tried

by PurpleSkys In reply to Acer Aspire AM1641 has no ...

hooking it up to another monitor to make sure it's not just the monitor?

Collapse -

This is what I've tried

by Bronn In reply to have you tried

different monitor, I put a video card in it and nothing, changed RAM, popped out the battery and replaced it, tried a boot disk and nothing but the same result...powers up, fans, dvd and the lights on the tower and that's it.

Collapse -

Well some diagnostics are in order here

by OH Smeg In reply to Acer Aspire AM1641 has no ...

But the telling thing is the No Beeps, No Video, it sounds like a faulty Power Supply.

I had a guy once replace the CPU, M'Board, RAM, HDD's, Optical Drive, Monitor before returning it to me for repair. It just needed a new Power Supply as the Low Voltage Circuit had died and was no longer producing enough current to run the CPU.

With that one I just supplied another case and a new PS and the guy went how with 2 computers instead of the one he brought off me.

Power Supplies produce several different Voltages and different currents so if one of those goes off marginally the computer stops working but the Fan's and maybe the LED's show activity even thought the computer isn't actually working.

Of course if it's been moved it's also possible that the Video Card has moved in it's socket and is no longer making the proper connection. You need to remove and refit the Video Card to make it work again. This is quite common with AGP Video Cards but I have seen one instance where a PCI Express Video Card moved and another where a WiFi Card had moved slightly and stopped working though the OS Showed that it was working correctly.

Happens quite a lot with cheap cases where the M'Board and any Plug In Cards do not fit quite right.

Col

Collapse -

The whole world

by santeewelding In reply to Well some diagnostics are ...

Including me, settles in a little more comfortable about these things.

Thank you, sir. Should mine -- hasn't yet -- misbehave, I'll be keeping in mind all the little hardware tidbits you so freely distribute like candy here.

Collapse -

Thanks

by Bronn In reply to Well some diagnostics are ...

I'm going to replace the power supply tommorrow and I'll post what happens:-)

Collapse -

I'd be hoping that it works

by NexS In reply to Thanks

'Coz if not, you'll probably be looking at a new motherboard, otherwise...

Collapse -

Hope not

by Bronn In reply to I'd be hoping that it wor ...

This is why I posted the question hoping someone smarter then me (no great accomplishment)might have some advice. I'm thinking it's the mb too.

Collapse -

Same situation just arrived at my shop today

by marcbf In reply to Hope not

Same computer, same thing - toast. I tested the PSU and it came up clean, and even tested with a known good PSU. Nada.

Caps look OK (no obvious bulging) so I am calling it dead and replacing with this from Newegg: http://www.newegg.com/Product/Product.aspx?Item=N82E16813500018

It is the only 775 board they have with the 7050 chipset - should be a very easy swap/re-activate Windows repair.

Collapse -

Thanks

by Bronn In reply to Same situation just arriv ...

I did try a different power supply and nothing. 44 bones from newegg...not too bad

Collapse -

Board worked

by marcbf In reply to Same situation just arriv ...

Well, the new board worked. Swapped it out and the machine booted right up - to a Vista crash.

Was hoping that it would find enough hardware the same to simply re-activate Vista, but unfortunately it didn't.

Tried numerous times to re-install wihtout nuking it, but no luck. I have Vista install disks with original, SP1, and SP2 but none would allow the "upgrade" repair install tricks.

In the end, I backed up the User accounts and did a clean install. Backing up was easy since Acer partitions the drive already so I just dragged the user account files over to , re-installed and then put them back. Hiren's boot CD helped with being able to boot the computer up to do the file transfer. BartPE would work just as well.

Back to Smartphones Forum
13 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums