Question

Locked

Acess denied unable to connect

By irshad84 ·
Non admin users on my network are able to print documents,but are not able to acess the printer spool or cancel documents.

i dont know why it happens.

only administrators are able to access printers.

it says"access denied unable to connect"

I tired this....
i have added users to print_operator group and even server_operator group,
still the same problem.

shared the inf folder on the root with everyone.
still does not work...

can anybody tell me of a solution
....
went to gpedit and found a setting under printers

allow print spooler to accept client connections..
i dont know whether this will work and i have to restart print spooler ...
can someone help me


Irshad

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

On right track with permissions

by Dedlbug In reply to Acess denied unable to co ...

First thing I would check: security tab of Printer. (I am sssuming the printer is shared from a Windows Server to a workstation. Correct me if wrong) Make sure "Creator Owner" exist and "Manage Documents" is checked ALLOW.

Some cases changing the permissions (on server) at "C:\windows\system32\spool\printers" for users can work as well.

Collapse -

still doesnt work

by irshad84 In reply to On right track with permi ...

Checked the security tab on printers.
they are fine(creator/everyone had full access)

the folder system32/spool has a problem

i tried sharing spool with print operators and server operators .it works

when i share with owner/creator..
it doesnt work

when i click apply ,it becomes unchecked again.
so there is definitely a security related issue

and i dont know how to solve it..

Collapse -

Share to print operators

by Dedlbug In reply to still doesnt work

That is normal behavior for the creator owner share in this case. You have to share to the group.

Some suggested shares to add:
Print Operators
Server Operators
Authenticated Users.
System
Administrators

Collapse -

Print Server?

by Kenone In reply to Acess denied unable to co ...

or shared printer off of a PC?

Collapse -

shared printer

by irshad84 In reply to Print Server?

It is a shared printer.

it is connected by tcp/ip
it is configured as a standard tcp/ip port on windows 2003 server.
printers are shared by the server and client computers connect to them as network printers.


one more issue,i am having problems publishing this printers in active directory.

i have allowed printers to be published but when i try to publish them i get an error

unable to publich printer .
try sharing it from the shared print folder.

this are my settings
--------->>>>>>>
Setting State
Allow printers to be published Enabled
Allow pruning of published printers Not configured
Automatically publish new printers in Active Directory Not configured
Check published state Not configured
Computer location Not configured
Custom support URL in the Printers folder's left pane Not configured
Directory pruning interval Not configured
Directory pruning priority Not configured
Directory pruning retry Not configured
Disallow installation of printers using kernel-mode drivers Not configured
Log directory pruning retry events Not configured
Pre-populate printer search location text Not configured
Printer browsing Not configured
Prune printers that are not automatically republished Not configured
Allow Print Spooler to accept client connections Enabled
Web-based printing Not configured

Collapse -

Security settings in group policy greyed out

by irshad84 In reply to shared printer

I have been searching for a solution,and found out that i need to make changes to security settings in group policy.(gpedit.msc)
allow users to access computer from the network.

but it is greyed out.

Collapse -

Domain policy has prevented it. (nt)

by seanferd In reply to Security settings in grou ...
Back to Peripheral Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums