General discussion

Locked

Active directory replication problem

By gregori65 ·
I added a new domain controller to a W2K domain, but when I tried to add a new user in the active directory I have this message: "The directory service was unable to allocate a relative identifier". On the Event Viewer I see the error message saying: "Source= SAM, the account-identifier allocator failed to initialize properly". I cannot create any account on this domain controller. Any idea?
Thanks for your help!!!

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Normax In reply to Active directory replicat ...

When adding a new domain controller the new controller might have tried to assume the role as the naming master or more likely the RID. As their can only be one in the forest this could be your problem.
Did you perhaps build your new controller by clone or image?
See this link discussing FMSO and how to change the roles.

http://support.microsoft.com/default.aspx?kbid=822053

Collapse -

by darts32 In reply to Active directory replicat ...

Try this.

Microsoft Knowledge Base Article - 839879

http://tinyurl.com/2cbca

Collapse -

by gregori65 In reply to Active directory replicat ...

Thanks for the link, it help me to understood the problem. Microsoft is telling me to use DOS command such as "repadmin" to fix the problem but it doesn`t seems to be a reconized DOS command.

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums