General discussion

  • Creator
    Topic
  • #2305251

    ActiveX can’t create object

    Locked

    by tstewart ·

    W2K OS, sqldmo.dll is in c:\windows\system32 but when I run regsrv32 c:\windows\system32\sqldmo.dll it fails to find sqldmo.dll file. Even when I go to system32 directory at command promt. Yet I can find sqldmo.dll file using search. Any ideas??

All Comments

  • Author
    Replies
    • #3538230

      ActiveX can’t create object

      by ncseric ·

      In reply to ActiveX can’t create object

      I have the SQL Server 2000 client tools (no database server) installed locally and my copy of SQLDMO.DLL is located here:

      C:\Program Files\Microsoft SQL Server\80\Tools\Binn\SQLDMO.DLL

      I ran regsvr32.exe on it and it registered fine. You mightbe missing some other files required for SQLDMO.DLL to work properly. The easiest thing to do is to reinstall the client tools for either SQL 7 or SQL 2000 on your machine. That should put all the files back in the correct places. If that doesn’t work, try uninstalling and reinstalling SQL. You can reattach any databases you have by using Enterprise Manager.

    • #3538162

      ActiveX can’t create object

      by madestroitsolutions ·

      In reply to ActiveX can’t create object

      that is simply not possible. Either the file is not there (see answer #1 above) or perhaps you might be typing “regsrv32” instead of “regsvr32” (notice the spelling difference ?)
      He he

      I also suggest reinstalling it.

      Good Luck!

    • #3520988

      ActiveX can’t create object

      by kanwaljit.jite ·

      In reply to ActiveX can’t create object

      Try using Depends utility provided in NT resource kit. This utility will help you figure out the missing DLLs for SQLDMO.dll. You can add those missing dlls to system32 or bin directory after which the registration should work fine..

    • #3521226

      ActiveX can’t create object

      by rrv ·

      In reply to ActiveX can’t create object

      In W2K, select the file or system32 folder and check the permissions for your userid. Make sure you have full control to your required dll.

      keep the file selected by clicking it in Explorer. Click start\Run and type “Regsvr32 ” (note. there is a space at last) and drag the dll file into this Run window’s text box. So the run command becomes “regsvr32 C:\Windows\System32\sqldmo.dll” (note. drive and folder names may differ) Run this command.

      You should see the dllselfregistry success message box.

      RV

Viewing 3 reply threads