Question

Locked

Add program to open with window

By afriqueart ·
I want to add a .exe to the open with window. When I click on "other programs" or browse, I'm able to navigate to the executable but, nothing happens to the "open with" window.

I've tinkered with my registry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mp3\OpenWithList

and the program is listed but, I still am not able to select it from the "open with" window.

Any suggestions would be appreciated.
Thanks

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try this -

by nepenthe0 In reply to Add program to open with ...

Check to see if application is listed in the Registry's Open With key:

HKEY_CLASSES_ROOT\Applications

To add a registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts

Look for the file extension whose Open With list you want to edit and find its OpenWithList subkey.

Credit to Preston Gralla, author of Windows XP Hacks (2005, O'Reilly Media), p. 112 for this suggestion.

Alas, you need to know how to competently ADD a registry subkey, and I'm not competent to advise you. But perhaps I've pointed you in the right direction.

Rick/Portland, OR

Collapse -

Easier method

by IC-IT In reply to Add program to open with ...

Right-click the icon of a file type that you want to modify, choose open with, choose the Choose program option, find the program on the list or browse to the location and select it. If you want this to always open with a double-click (or single if you set your prefs that way) insure you check the box, otherwise just ok.
Now that program should be listed as a choice under open with.

Collapse -

Still cannot modify the Open With List

by Boat Guy In reply to Easier method

I have tried the method suggested, but still no success. I have an Open Office spreadsheet file (.ods) and it somehow has gotten the Adobe Reader 8.1 icon attached to it. When I go to File Types to try to chnage the program in the Open With list, the one I need, scalc.exe is not a choice. If I try to add it, I can browse to it, but when I select it and say <Open>, nothing happens. Very frustrating.

Collapse -

Open windows explorer

by Kenone In reply to Add program to open with ...

NOT IE
click on "Tools" - "Folder Options" - "File Types"
Scroll down and find your .ods file type, highlight it, what does it say below the box? Click the change button to associate it with a different program. I think you want to associate it with the calc program.

Collapse -

Did that - It does not work

by Boat Guy In reply to Open windows explorer

I have tried that several times. When I go to Tools>Options>Folder Types the .ods file type says it opens with Adobe Reader 8.1

I select "Change"

Window Title is "Choose the program you want to use to open this file"

scalc.exe is NOT in the list

"Browse" and locate the file, select it and select "Open"

That has no effect...I am returned to the "Choose the program..." window and scalc.exe is still not there.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums