Question

Locked

Add to dictionary item grayed out in all Office 2007 apps

By thuckstep ·
I've been running Office 2007 for a couple of weeks now and note that, when I misspell a word, get the red squiggle underling, right click on the word, the option to "add to dictionary" is grayed out, unavailable. Do any of you have a solution to this? I've searched the endless loops of Microsoft support pages and still not found the solution.

Thanks!

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

re Add to dictionary in Office 2007 apps

by ThumbsUp2 In reply to Add to dictionary item gr ...

I'm not exactly sure where Office 2007 stores the custom dictionary and I'm not sitting in front of one, so I can't be too specific. But, if you're using a server, it may be stored there and you don't have permission to change it. It's also possible the custom dictionary is corrupt, missing or turned off. You also need to check your language toolbar to make sure the correct language is set.

To check where your custom dictionary is located, using Word (cuz it's the easiest), 1. Click the Microsoft Office Button, and then click Word Options. 2. Click Proofing. Look for the setting for "Custom Dictionary". Look to see if there IS a custom dictionary set. If there is a file set, use the "Detect and Repair" feature to fix it. If there is no file set, the option to add to it WOULD be grayed out on your right click. You may need to install additional proofing tools to get the custom dictionary feature.

And, one last article that I read said that if you upgrade from previous Office versions to Office 2007, SOME of the older proofing tools will not work at all. This indicates that perhaps Office 2007 has it's own proofing tools to be installed?

So, before we can go further, we really need more information about your system, type of Office 2007 installation and other conditions that may affect how Office 2007 fuctions for you.

Collapse -

re Add to dictionary in Office 2007 apps

by thuckstep In reply to re Add to dictionary in O ...

Thanks ThumbsUp2. Your reply clarified my thinking on this and I came up with the solution. This involves the fact that CUSTOM.DIC files created in prior versions of Office were not saved as Unicode files. Office 2007 requires this. So I simply opened my existing CUSTOM.DIC files left over from Office 2003 in Notepad, clicked File/Save As and chose the file type Unicode. Then, when I went back to test misspelled words in Word 2007, all was well.

Collapse -

That's great! :)

by ThumbsUp2 In reply to re Add to dictionary in O ...

Glad to know the fix wasn't too hard at all. I was afraid it was something more complicated. I'll have to save THAT one in the old "memory banks", as I'm sure the question will come up again.

Collapse -

Add to Dictionary fixed

by the_epoch In reply to Add to dictionary item gr ...

I had to create a new custom dictionary to fix the problem.

Find the file path of your existing custom dictionary (mine was C:\Users\username\AppData\Roaming\Microsoft\UProof) and rename your existing dictionary.


The to actually create the new dictionary I did this through the Office interface, either Word - "Word Options > Proofing > Custom Dictionaries" or Outlook - "Tools > Options > Spelling > Spelling and AutoCorrection > Custom Dictionaries"
Then select New and give your custom dictionary a name; the default is CUSTOM.
After that close all Office apps and restart them.
Now my "Add to dictionary" option in Office 2007 works.

Collapse -

a simple dodge

by robw48 In reply to Add to dictionary item gr ...

I have this problem all the time especially when I cut & paste from another document

I've just discovered if you right-click on the offending word, go down to "languages" in the drop down box, you get to see which one it's using for that word (the wrong setting normally). If you click on the default at the top (which is normally the one you've set through the whole Options rigmarole and you want for the dictionary) and then go back to the offending word you can add it to the dictionary - the greyed out bit has gone.

Heaven knows WHY this happens but its a quick-ish workaround if it's only a few words - of course it would be nice if the Options song & dance worked consistently but it is Microsoft after all

Collapse -

Another Fix..

by stevejay In reply to Add to dictionary item gr ...

It could be the Custom Dictionary and document languages are not in sync. I found that my doc was English (US) and my dictionary was Spanish (? - not sure how that happened). When I put both of them as "English (Canada)", the problem was solved...

Back to Software Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums