Question

Locked

Adding a DSL route to a Cisco 2611 router

By deity_chooch ·
Hi, all! I'm having an issue getting a Cisco 2611 router to use a DSL router as a gateway and am not skilled enough in Cisco to determine the problem.

I've got the DSL router connected via ethernet to the Ethernet0/1 port on the Cisco and have the following configuration for it:

interface Ethernet0/1
bandwidth 7168
ip address 75.160.162.65 255.255.255.192
ip access-group 120 in
ip ospf authentication-key 7 047803570C204B1E
no ip mroute-cache
full-duplex
no cdp enable
!

The access-list in question is as follows:

access-list 120 permit icmp any any
access-list 120 permit ip 75.160.162.64 0.0.0.63 any
access-list 120 permit ip 172.16.0.0 0.0.255.255 any
access-list 120 permit ospf any any
access-list 120 deny ip any any

The DSL router's IP address is 75.160.162.126/26, which pings from the Cisco router whether the ethernet cable is connected or not. I've also just discovered that I'm unable to ping the IP address of the Cisco's Ethernet0/1 interface (75.160.162.65/26) from the Cisco. I'm stumped on this and would appreciate any help you folks can give. Thanks!

This conversation is currently closed to new comments.

23 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Am I correct

by NetMan1958 In reply to Adding a DSL route to a C ...

that you are saying you can disconnect the cable that connects the Cisco interface Ethernet0/1 to the DSL router and still ping the router (75.160.162.126)?

Can you post the complete configuration?

Collapse -

Yes, that's correct

by deity_chooch In reply to Am I correct

Yes, I have had the Cisco router disconnected from the DSL router for some time, and can still ping the DSL router (through the currently connected Internet interfaces, I'd assume). I thought when I added the IP information to the Cisco 2611 that it would start reading the subnet as attached to the Ethernet0/1 interface, but that doesn't seem to be the case. I have noticed that when I ping that address with the ethernet connected, I get much quicker ping times than otherwise, as illustrated below:

Ethernet connected:

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Ethernet disconnected:

Success rate is 100 percent (5/5), round-trip min/avg/max = 116/121/129 ms

Thanks much for your assistance! The full router configuration follows:

Current configuration : 5203 bytes
!
! Last configuration change at 17:32:04 UTC Thu Aug 13 2009
! NVRAM config last updated at 23:24:53 UTC Tue Aug 11 2009
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname rdtgf2611-1.backbone.sofast.net
!
enable secret 5 $1$gejH$AgjjVco9/nCOyETfa$/2$z0K0Yj.
!
ip subnet-zero
ip cef
!
!
ip name-server 204.120.163.4
ip name-server 208.35.255.89
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.255.2 255.255.255.248 secondary
ip address 204.120.160.2 255.255.255.248
no ip redirects
ip ospf authentication-key 7 02250C0A08B4C87F1070871
no ip mroute-cache
half-duplex
no cdp enable
!
interface Serial0/0
description Point to Point Connectivity
bandwidth 1544
ip address 204.120.160.170 255.255.255.252
ip load-sharing per-packet
rate-limit input access-group 102 128000 8000 8000 conform-action transmit exceed-action drop
ip route-cache flow
no ip mroute-cache
no cdp enable
!
interface Ethernet0/1
description Qwest 7Mbps DSL - Internet
bandwidth 7168
ip address 75.160.162.65 255.255.255.192
ip access-group 120 in
ip ospf authentication-key 7 047803570F134F1CC204B1E
no ip mroute-cache
full-duplex
no cdp enable
!
interface Serial0/1
description Sprint T1 - Internet
bandwidth 1544
no ip address
rate-limit input access-group 102 128000 8000 8000 conform-action transmit exceed-action drop
ip route-cache flow
shutdown
no cdp enable
!
interface FastEthernet1/0
bandwidth 1536
ip address 63.166.59.189 255.255.255.252
ip load-sharing per-packet
ip route-cache flow
duplex auto
speed auto
no cdp enable
!
router ospf 1
log-adjacency-changes
area 0.0.0.0 authentication
network 204.120.160.0 0.0.0.7 area 0.0.0.0
network 204.120.160.8 0.0.0.7 area 0.0.0.0
default-information originate metric 10
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 63.166.59.190
no ip http server
ip pim bidir-enable
!
access-list 3 permit 208.35.255.0 0.0.0.255
access-list 3 permit 208.49.95.0 0.0.0.255
access-list 3 permit 208.51.255.0 0.0.0.255
access-list 3 permit 204.120.160.0 0.0.0.255
access-list 3 permit 204.120.161.0 0.0.0.255
access-list 3 permit 204.120.162.0 0.0.0.255
access-list 3 permit 204.120.163.0 0.0.0.255
access-list 3 permit 63.166.59.0 0.0.0.255
access-list 3 permit 63.164.8.0 0.0.0.255
access-list 3 deny any
access-list 5 permit 208.35.255.2
access-list 5 permit 208.35.255.3
access-list 98 permit 204.120.163.24
access-list 98 permit 208.35.255.66
access-list 98 permit 208.35.255.67
access-list 98 deny any
access-list 102 permit icmp any any echo
access-list 102 permit icmp any any echo-reply
access-list 110 permit ip any host 208.35.255.2
access-list 110 permit ip any host 208.35.255.3
access-list 110 permit ip any host 208.35.255.126
access-list 110 permit tcp any host 208.35.255.49 eq smtp
access-list 110 permit tcp any host 208.35.255.49 eq 443
access-list 110 permit tcp any host 208.35.255.49 eq 143
access-list 110 permit tcp any host 208.35.255.49 eq pop3
access-list 110 permit ip any host 208.35.255.123
access-list 110 permit ip any host 208.35.255.14
access-list 110 permit ip host 204.120.160.42 any
access-list 110 permit ip host 204.120.163.4 any
access-list 110 permit tcp any any eq www
access-list 110 permit tcp any any eq 443
access-list 110 permit tcp any any eq ftp-data
access-list 110 permit tcp any any eq ftp
access-list 110 permit tcp any any eq 22
access-list 110 permit icmp any any echo
access-list 110 permit icmp any any echo-reply
access-list 110 deny ip any any
access-list 120 permit icmp any any
access-list 120 permit ip 75.160.162.64 0.0.0.63 any
access-list 120 permit ip 208.35.255.0 0.0.0.255 any
access-list 120 permit ip 204.120.160.0 0.0.0.255 any
access-list 120 permit ip 172.16.0.0 0.0.255.255 any
access-list 120 permit ospf any any
access-list 120 deny ip any any
cdp timer 5
cdp holdtime 10
no cdp run
snmp-server engineID local 00000009020000E08F29D000
snmp-server community CommunityOmitted RO 98
snmp-server location Cisco 2611-1 Core Router, DownTown, Great Falls, MT
snmp-server contact Matthew Washington [mattheww@sofastmail.net]
snmp-server enable traps tty
snmp-server enable traps config
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps frame-relay
snmp-server host 204.120.163.24 1Lwrath
snmp-server host 208.35.255.66 1Lwrath
snmp-server host 208.35.255.67 1Lwrath
!
dial-peer cor custom
!
!
!
!
banner login ^CCC
********************************************************************************
This is a private system operated for and by
SoFast Internet Services LLC.

Authorization from SoFast Internet Services LLC management is required to use this system.

Use by unauthorized persons is prohibited.
********************************************************************************
^C
!
line con 0
password 7 13361522C4FF3C135F1F17787B747B
login
line aux 0
line vty 0 4
access-class 3 in
exec-timeout 0 0
password 7 13361522C4FF3C135F1F17787B747B
login
!
ntp clock-period 17179878
ntp access-group peer 5
ntp server 208.35.255.3
ntp server 208.35.255.2
end

Collapse -

OK it makes more sense now

by NetMan1958 In reply to Yes, that's correct

You have multiple circuits connected to that router so that makes more since now. Are you wanting to route specific traffic over this particular DSL circuit or are you wanting to include it in load balancing?

Also, do you know if that DSL circuit uses PPPoE? I kinda doubt it in this case but it doesn't hurt to ask.

Reconnect the router to the DSL and run "show interface Ethernet0/1"
run "show ip route"

and post the output.

Collapse -

Output for requested commands

by deity_chooch In reply to OK it makes more sense no ...

I'm wanting to include this new connection in the load balancing, and the DSL circuit does nut use PPPoE. Following is the output from the commands you've requested:

show interface Ethernet0/1:

Ethernet0/1 is up, line protocol is up
Hardware is AmdP2, address is 0002.fd45.b361 (bia 0002.fd45.b361)
Description: Qwest 7Mbps DSL - Internet
Internet address is 75.160.162.65/26
MTU 1500 bytes, BW 7168 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:16, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
36160 packets input, 2179058 bytes, 0 no buffer
Received 35802 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
41247 packets output, 3924136 bytes, 0 underruns
1142 output errors, 0 collisions, 7 interface resets
0 babbles, 0 late collision, 9 deferred
1142 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

show ip route:

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.16.0.0/28 is subnetted, 1 subnets
O 172.16.41.0 [110/15] via 204.120.160.1, 1d22h, Ethernet0/0
204.120.160.0/24 is variably subnetted, 2 subnets, 2 masks
C 204.120.160.0/29 is directly connected, Ethernet0/0
C 204.120.160.168/30 is directly connected, Serial0/0
192.168.255.0/29 is subnetted, 1 subnets
C 192.168.255.0 is directly connected, Ethernet0/0
63.0.0.0/30 is subnetted, 1 subnets
C 63.166.59.188 is directly connected, FastEthernet1/0
208.35.255.0/24 is variably subnetted, 3 subnets, 2 masks
O 208.35.255.0/28 [110/15] via 204.120.160.1, 1d22h, Ethernet0/0
O 208.35.255.48/28 [110/15] via 204.120.160.1, 1d22h, Ethernet0/0
O 208.35.255.64/26 [110/15] via 204.120.160.1, 1d22h, Ethernet0/0
75.0.0.0/26 is subnetted, 1 subnets
C 75.160.162.64 is directly connected, Ethernet0/1
S* 0.0.0.0/0 is directly connected, Serial0/0
[1/0] via 63.166.59.190

Collapse -

What is each interface supposed to do?

by CG IT In reply to Yes, that's correct

you've got your Serial 0/0 with PPP your Serial 0/1 with no addressing, your ethernet [10base] with a nonroutable secondary address [subinterface] and your FastEthernet with a routable address

Collapse -

Interface purposes

by deity_chooch In reply to What is each interface su ...

Serial0/0 is a point-to-point 1.544Mbps line connected connected to an AdTran TSU LT, then out via T1.

Serial0/1 is not connected to anything and is unused.

Ethernet0/0 is connected to a switch and the rest of our network

Ethernet0/1 is connected to the DSL router which I want to configure as an additional, load-balanced gateway to the Internet.

FastEthernet1/0 is a connected to a different DSL router, over which traffic is passing just fine.

Collapse -

Ah ok thanks that makes much more sense

by CG IT In reply to Interface purposes

ip load-sharing per-packet

equal cost routes for both interfaces [the E0/1 and the Fe1/0]

ip route X.X.X.X X.X.X.X E0/1 10
ip route X.X.X.X X.X.X.X FE1/0 10

Collapse -

No throughput when route is added

by deity_chooch In reply to Ah ok thanks that makes ...

I've added the following command to the router, but when I remove the other two routes (to verify traffic is going through the new one), throughput stops completely:

ip route 0.0.0.0 0.0.0.0 Ethernet0/1

Am I missing something? We are eventually going to get rid of the other two Internet connections (Serial0/0 and FastEthernet1/0), which is why I didn't use the metric when adding the route.

Also, just out of curiosity, why does your command have the ip route going out the interface instead of the gateway IP? Is there a difference, or just a matter of semantics?

Collapse -

Use the ip address

by NetMan1958 In reply to No throughput when route ...

of the gateway on ethernet0/1 instead of the interface...I believe it was .126.

then run "show ip route 0.0.0.0"

Collapse -

Output of ip route

by deity_chooch In reply to No throughput when route ...

Okay... I found some additional information I find interesting (perhaps puzzling). I added the route using the gateway address (75.160.162.126/26) with the following command:

ip route 0.0.0.0 0.0.0.0 75.160.162.126

I then removed the other routes to see if traffic was flowing. I tried a ping through a computer on the network and found no packets getting through. The interesting part is that, from the Cisco router, I was unable to ping names, but able to ping IP addresses:

ping google.com:

Translating "google.com"...domain server (204.120.163.4) (208.35.255.89)
% Unrecognized host or address, or protocol not running.

ping 74.125.45.100:

Sending 5, 100-byte ICMP Echos to 74.125.45.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/97/100 ms

Now I'm confused, as both DNS servers are allowed through access-list 120. I checked the output from the "show ip route" command before and after running these pings.

Before:

Routing entry for 0.0.0.0/0, supernet
Known via "static", distance 1, metric 0, candidate default path
Routing Descriptor Blocks:
* 75.160.162.126
Route metric is 0, traffic share count is 1

After (I also put the other routes back in):

Routing entry for 0.0.0.0/0, supernet
Known via "static", distance 1, metric 0 (connected), candidate default path
Routing Descriptor Blocks:
* 75.160.162.126
Route metric is 0, traffic share count is 1
directly connected, via Serial0/0
Route metric is 0, traffic share count is 1
directly connected, via FastEthernet1/0
Route metric is 0, traffic share count is 1

Back to Networks Forum
23 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums