General discussion

Locked

advanced windows settings

By Mike (from Canada) ·
I have an AT compatible computer with support for ISA hardware cards only. I use windows 95 often on it.

#1) There are a number of (what I call dummy) devices that begin with a star. For example, *ebios, and *ios. Where can I find the definitionsfor each of the devices supported by Windows 95 that begin with a star?

#2) How do I change CPU and device priority in Windows?

My objective is to get Windows 95 running as fast as Windows 3.1. I have tried unloading unnecessary drivers and files.

Another thing I noticed is that Windows needs mprexe.exe to load as well. I used a utility and it pointed out that mprexe.exe was a background network app for windows (or something like that).
I never do networking through windows, and whenI tried renaming it, Windows wont load!!!

Please help me. I am looking for answers. Registry Settings, System.ini settings are also helpful.

I tried Axcel216 page and they didnt help that much.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

advanced windows settings

by TheChas In reply to advanced windows settings

On a given hardware configuration, W95 will run around 20% slower than W3.1.

There is just more code and overhead for the PC to deal with.

The same is true when you compare W95 and W98.

In my experiance, it is best to leave many of the performance "tweaks" alone.

I recommend the following;
Keep the services in the system files (autoexec.bat, config.sys, win.ini, sys.ini) to the absolute minimum.
In System Properties / Performance, set the system type to network server. This speeds up many file transfer operations.
Clear out the W95 Startup items on the programs menu. Load only those programs that you truely need.
In the registry, clean out the run, runonce and runonce except keys.
It is also useful to "compact" the registry.
There is an article on this at www.aumha.org

Keep device drivers up to date.

Perhaps the best way to "speed up" W9X is a fresh install onto a clean hard drive.

You need around 128MB of RAM for W95 to run efficiently. Any less, and it spends too much time swapping data to the hard drive. Much more, and it may actually slow down.

As I said at the beginning, even at it's optimum, W95 will run around 20% slower than W3.1 on a given system.

Chas

Collapse -

advanced windows settings

by Mike (from Canada) In reply to advanced windows settings

Poster rated this answer

Collapse -

advanced windows settings

by Shanghai Sam In reply to advanced windows settings

There are a number of things you can do.

Go to START/RUN and type SYSEDIT and manually add (or change if already there) the following items:

In CONFIG.SYS:
Add the following in this order:
DEVICE=C:\WIN\HIMEM.SYS /HMAMIN=40 /TESTMEM:OFF
DEVICE=C:\WIN\EMM386.EXE NOEMS I=B000-B7FF
FILESHIGH=60
BUFFERSHIGH=17,0
STACKSHIGH=0,0
SWITCHES=/F
DOS=HIGH,UMB
SHELL=C:\COMMAND.COM C /E:400 /P
DEVICEHIGH=C:\IFSHLP.SYS
If there are any other drivers, change the prefix DEVICE= to DEVICEHIGH=in all instances.

In AUTOEXEC.BAT:
Prefix all commands with LH - for example:
C:\MOUSE\MOUSE.COM - change it to:
LH C:\MOUSE\MOUSE.COM

In SYSTEM.INI:
Add the following statements to the [386Enh] section:
PerVMFiles=20
MaxBPs=1177
Leave all devices starting with * as they are: these are system files set up (and needed by) Windows.

Next navigate to the [vcache] section and add the following:
MinFileCache=nnn
MaxFileCache=nnn
ChunkSize=512
where nnn should be 25% of your total RAM; so for 64MB, type 16384; for 128MB type 32768 etc. Just the number, 32768, not 32768MB!

In CONTROL PANEL/SYSTEM/DEVICE MANAGER:
Go to Disk Drives and click on the + drop down. Select your hard disk, click on PROPERTIES/SETTINGS and see if the DMA box is checked. If not, check it and ignore the warnings.

Go to VIRTUAL MEMORY and change it to:
"Let me specify my own virtual memory settings", then change as follows:
For both Maximum and Minimum, put in 2.5 times the amount of memory your machine has, for instance if you have 128MB, then put in 320 in each. Again, just the number.

Back up your registry first, then go to START/RUN/REGEDIT

Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\BIOS
In the right hand pane create a new DWORD value called "CPUPriority" (no quotes). Double click on it and check the Decimal box. Type 1

clover

Collapse -

advanced windows settings

by Mike (from Canada) In reply to advanced windows settings

Poster rated this answer

Collapse -

advanced windows settings

by R. A. Caluste In reply to advanced windows settings

Try decreasing the number of fonts, the more fonts you have in your c:\windows\fonts folder, the longer it takes for the system to load all fonts! I remember a friends with a kicka$$ machine. He installed the entire contents of the font collection on a CD to his fonts folder. Now everytime he boots, he waits much longer than he used to.

Collapse -

advanced windows settings

by Mike (from Canada) In reply to advanced windows settings

Poster rated this answer

Collapse -

advanced windows settings

by Mike (from Canada) In reply to advanced windows settings

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums