Question

After Windows 10 Oct 2018 update, I can no longer boot to Linux

By jim_trahan ·
I have an Acer ES 15 laptop in a dual boot setup, Windows 10 and Linux Mint 19.1. I installed the October 2018 update a few days ago, and it destroyed my ability to boot to Linux, going directly into Windows without giving me the choice to boot to Linux. I booted to my Linux Mint live CD and found that the Linux partition is still intact with all files visible, but no boot capability. I downloaded and ran the grub boot repair utility from within the live CD environment, it completed successfully and said the grub file was repaired, but still no boot to Linux. Will I have to wipe the Linux partition clean and do a reinstall to restore my Linux bootup option? Or is there any other option to save my current installation and regain access?
10 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Answers

Collapse -

You may have to disable Secure Boot in UEFI/BIOS

by wizard57m-cnet Moderator In reply to After Windows 10 Oct 2018 ...

Not knowing what key, normally you press F2, F12 etc to get into UEFI/BIOS setup. Try that, IIRC Windows 10 UEFI Secure Boot blocks grub bootloader (as well as others).

Collapse -

Thanks, but...

by jim_trahan In reply to You may have to disable ...

I disabled secure boot before running boot repair, and it remains disabled. No go. Thanks anyway.

Collapse -

Try this, from an older Linux Mint forum post

by wizard57m-cnet Moderator In reply to After Windows 10 Oct 2018 ...

OK, finally got this fixed.

This is how to restore grub after a Windows install/re-install overwrites the MBR. The grub configuration is still there, it just isn't being loaded at boot up.

Boot from a LIVE DVD (in my case Linux Mint 11)

I knew which partition LM 11 was installed on. In my case it was sda6. In your case it will most likely be different.
If you don't know, you can determine the partition that Mint is installed on by:
Open terminal and run
sudo gparted
Look for the large EXT4 partition and make a note of what it says on the far left such as sda6
Close gparted

In terminal enter:
sudo mount /dev/sda6 /mnt (replace sda6 with whatever is appropriate for your system)
sudo grub-install --root-directory=/mnt /dev/sda (note there is a space between mnt and /dev and do not put a number after sda)

Restart the computer and you should have your grub menu available again.

Open terminal and enter
sudo update grub (This might not be necessary, but can't hurt)

Note: I did not write this original post, so I can't answer 100 percent it will work. As the poster noted, replace your SDA number as you find in gparted.
Wiz

Collapse -

Thanks!

by jim_trahan In reply to Try this, from an older L ...

Will try this later today, when I have some time to devote to it. Much appreciated! Will let you know if it fixes the issue. :-)

Collapse -

Okay just tried this suggestion...

by jim_trahan In reply to Try this, from an older L ...

Here's what happened when I ran the commands in terminal:

mint@mint:~$ sudo mount /dev/sda5/mnt
mount: /dev/sda5/mnt: can't find in /etc/fstab.
mint@mint:~$ sudo mount /dev/sda5 /mnt
mint@mint:~$ sudo grub-install --root-directory=mnt /dev/sda
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
mint@mint:~$

I think this might be because on this Win 10 laptop, Windows boots using UEFI and Windows Boot Manager rather than BIOS and MBR? Is there any other option?

Collapse -

OK what I think has happened here

by OH Smeg In reply to After Windows 10 Oct 2018 ...

Is that the Windows Update has destroyed the Grub Boot Loader.

This happens when you install a Linx Distro after Windows and it defaults to using the Grub Boot Loader that comes with your Nix Distribution.

Unfortantly this is a common issue with Windows as it doesn't like to play well with other OS's unless you let it control everything.

What you need to do here is not rebuild the Grub Boot Loader but build a Windows Boot Loader so Windows doesn't trash it every time you apply a new update.

As I'm not a Win 10 Expert I would suggest going to Technet and looking up there what you need to do but an easy way is to rebuild Windows by doing a repair install which will leave your existing software and data alone and just fix what is broken in Windows which in this case is the Boot Loader.

However as I've said I'm no 10 Expert and there may be an easier/faster way of doing this but as MS changes everything around with each new version I wouldn't even hazard a guess on the easiest way to proceed.

The answer above should repair the Grub Boot loader but I think you'll find that every time you get a Substiantial Windows Update it's going to trash the Grub and you'll be forced to rebuild it every time. Part of the fun of using Windows I suppose but it's a real nusiance.

Of course if that is not the case and the Nix Distro was the first installed ignore the above.

Collapse -

As I understand it...

by jim_trahan In reply to OK what I think has happe ...

Windows does not play nice with Linux. I've been told that to dual boot Windows and Linux, Windows MUST be installed first, then Linux. Linux grub will include the Windows boot manager as a boot option, but Windows will not recognize a Linux install, and therefore will not provide an option to boot to Linux if installed after Linux. So according to that line of thought, as I understand it, the only way to fix this issue is to set up grub as the boot loader.

Collapse -

As I said I'm not sutre on the 10 front

by OH Smeg In reply to As I understand it...

But from previous experience Windows doesn't play nice even with different versions of Windows.

The system I'm using here has 5 different OS's 3 Windows XP Pro, 7 and 10 then Linux Debian the latest version and Red Hat the XP Pro install being the last one and it reconises all installed versions except the extra HDD used to store Data which is a NTFS Partition..

I use a different HDD for each OS and another for data so it can be shared across all OS's .

While I'm not sure on 10 as I don't really use it XP Pro was the last installed here after a Windows Update wrecked the Grub Boot Loader and allowing XP to do the initial Boot works fine even if newer versions do play havock with the Boot loader at times.

I do however know 10 has it's limitations and it very much depends on which version of 10 you are using here so if it's one of the lower versions not reconising Linux Partitions may very well be correct.

Collapse -

It is Windows 10 Pro...

by jim_trahan In reply to As I said I'm not sutre o ...

And just updated to the October 2018 release, 180**4-1434.

Collapse -

I've decided to give up doing dual boot on the Acer...

by jim_trahan In reply to After Windows 10 Oct 2018 ...

My last resort was to delete the Linux partition, then do a reinstall of Linux Mint on the unallocated space, with the "Install Linux alongside Windows and select which OS to boot at each bootup" option. After installation completed, there was still no dual boot option on restart. So I will just delete the Linux partition again, and reclaim the unallocated space to the Windows partition. I have an old Toshiba laptop from 2009 that I will pull out of retirement, wipe the hard drive, and install Linux to that machine. Windows 10 is a GIANT step backward in user friendliness!

Back to Linux Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums