General discussion

AMD Graphics Card Issue After Latest Windows 10 Update

By jaisongomes ·
Tags: Windows
Greetings community,

The problem started after I updated Windows this morning to Windows 10 (64 bit) Version 10.0.16299 Build 16299. After installing, I browsed the web for a little bit after, and an hour or so ago started a game of Heroes of the Storm. The game crashed while loading a game. I booted it back up and it played normally for about 3 minutes with ~160 FPS at max settings, after which both of my monitors switched off (sound was still working fine). I smelled something like plastic burning, and the power button on the computer went solid red. I turned it off with the power button and let it sit for a few minutes while I opened up the tower to take a look at things.

The GPU seemed warm, but not unusually hot. I couldn't confirm whether the fans had been working. The fan on the processor seemed to be fine.

I grabbed a spare HDMI cable and plugged the main monitor into the mobo directly, and looked at some help forums while I downloaded the newest AMD software. Running that brought up an Error 173: AMD Graphics Hardware Was Not Found. I tried three different AMD installations (the main driver software suite, the AMD chipsets, and the more bare-bones Catalyst I believe), all of which bailed out after returning that error.

I then checked all the cables and connections to make sure everything was OK on that front. Haven't found any problems but I'll keep troubleshooting it.

I'm suspecting something with the Win10 update messed with the card and now it's overheated and bricked itself. Any inklings of what I can try to get things working again?

I've pulled out the graphics card and reinserted it plus checked the connections to make sure everything's hooked up properly.

When I plug either monitor into the GPU, it changes from "not connected" to "no signal." Not sure if that helps at all.

I've also run Display Driver Uninstaller and redownloaded AMD software version 18.1.1, but it still won't install, giving me the same Error 173, saying there's no AMD graphics hardware.

Between everything else failing and the brief burnt plastic smell right as it failed last night, I'm suspecting the card itself has been damaged.
1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Galactica IT Solutions

by GalacticaIT In reply to AMD Graphics Card Issue A ...

We are Galactica IT Solutions offer wide professional expertise in supporting the public, professionals and companies.

We send engineers to any location within the UK & Ireland.

Set up by Lee Strachan in full accreditation by Microsoft and partners, Lee has noticed the increase in value for money hit out the roof.

Galactica IT Solutions is and will be the cheapest on the market and still using licenced products and expectations at its highest for less.

Some of the things we offer:
- Windows & Windows 10 Approved engineers
- Desktop/ Laptop Repairs (cosmetic & hardware)
- Network/ Server diagnosis & repairs
- Workstation setups
- Network set ups and Domains
- Printer repairs & diagnosis
- LAN/ WAN set ups
- Ordering Products
- 24/7 callout emergency contact centre
- Helpdesk Support
- Smartphone Repairs
- Tablet Repairs
- Graphics Card & Component installation

We are on Facebook & Instagram
Why not give us A follow!

https://www.facebook.com/GalacticaIT/

Back to Windows Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums