Another file that won't delete

By caroline.witte ·
I have the same problem as another poster,EG, a file that will not delete, and have tried everything, even deleting it in 'safe mode'. It won't delete. I get the message "cannot delete file; cannot read from the source file or disk." I've tried renaming it, and everything else I can think of doing. It too is '0 bytes', and it is called ' CAD7V22T'. My computer doesn't recognise the file type, although the icon is just a 'general' file icon. It's been on my desktop for nearly 2 months now. Oh, it is 'greyed out' but still noticeable. It's really frustrating. I have NO idea where it came from. It just showed up one day when I rebooted my computer. I have googled CAD7V22T and found nothing. So, if anyone out there knows anything about it, please let me know as well. Oh, I am using Win XP Media Edition. I have scanned it with various virus programs as well as various malware detectors, and it has never been 'flagged' by any of them. It will also not move to another location.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Check out this Microsoft knowledge base bulletin

by nepenthe0 In reply to Another file that won't d ...
Collapse -

Just an idea ...

by OldER Mycroft In reply to Another file that won't d ...

Depending on the size of your System Restore, if you check for the date that's the same as this file, you might find what you installed at that time.


Collapse -

See if this helps

by Jacky Howe In reply to Another file that won't d ...

Have you tried this program.

Copy and paste the info between the ==== signs into Notepad and save the file to the desktop as d1.bat and run it if it does'nt work try it again in Safe Mode.

cd %USERPROFILE%\desktop
del *CAD7V22T.* /q

Collapse -

Use one of my favorite little file tools...

by CaptBilly1Eye In reply to Another file that won't d ...

It's called Unlocker.
It will add a right-click context menu choice to 'unlock' a file or folder.

I use it primarily when a file is locked by a program. You know... when you get the message saying "The file is in use by another program or user." or something similar. However Unlocker also provides the option to Delete. It it can't, it will on the next boot. So, I think it'll work for your situation as well. Oh... did I mention... it's FREE. :)
Here's where you can get it:

One small note - During the installation, Uncheck all the options except 'Explorer Extension.' All the others are unnecessary.

Let me know if that helps.

Collapse -

Thanks, Captain Billy!

by nepenthe0 In reply to Use one of my favorite li ...

A perfect utility - what a great find! I shall put it to good use.

Much appreciated, my friend.

Rick/Portland, OR

Collapse -

Think out of the box

by techgecko In reply to Another file that won't d ...

I had an unmovable file with exactly the same properties but was unable to remove it using everything I found including all the other suggestions put forward here. I have another partition with Studiobuntu installed ..dohhhh. It saw the file, deleted it (moved it to the proper recycle bin) and even reported a believable file size of 28kb. Then on rebooting XP I successfully emptied it from trash. Linux Rocks. It should work just as well if you use a live CD. Download iso and burn a disc from

Related Discussions

Related Forums