Anyone had any joy in getting Windows 7 Drivers

By HAL 9000 Moderator ·
to work with the 64 Bit Version of Windows?

I have a Canon LIDE30 Scanner which has 7 Drivers but the Driver shows as not loaded when it's installed onto a 64 Bit Version of Home Premium.

Because it's Home Premium there is no XP Mode available and Canon doesn't list any 64 Bit Drivers for this Model Scanner.

Of course the fact that they have 7 Drivers and Software didn't help when I originally looked at supplying a new NB for this customer and the fact that I got him to run the Windows 7 Compatibility Tool and everything passed hasn't helped either.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

I've been

by boxfiddler Moderator In reply to Anyone had any joy in get ...

too busy looking over my shoulder keeping an eye on you to be hunting down 64 bit drivers.

Collapse -

You could install the 32 bit driver

by Michael Jay In reply to Anyone had any joy in get ...

Twice, then it would be a 64 bit driver?

Yikes I hear airlock doors swinging and open.. :)

Run away..

Collapse -


by OH Smeg Moderator In reply to You could install the 32 ...

If you can hear the Doors opening it's way too late for you.

There is a loud sound of Air rushing out the doors as they open a fraction and it's at that stage where you can get sucked through the opening.

If you can hear the doors opening then you are relatively safe and have 3 minutes of life left. It takes that long to freeze solid. You are long dead before a lack of Oxygen can have any effect. :^0

edited to add OH I should add I did try installing it twice but that didn't work either.

I also tried using the Canon Driver Removal Tool quite a few times to remove the 32 Bit Driver and every time I ran it it supposedly removed the driver. Either it's telling me Lies or the Driver isn't being removed. :0


Collapse -

Your airlock drivers

by santeewelding In reply to Michael

Have been seen to by Stuxnet. I saw to it.

Collapse -

It's my understand that the Airlocks

by OH Smeg Moderator In reply to Your airlock drivers

On Discovery have failed to Space Weld themselves shut through a lack of use.

It just shows what a well designed and engineered device is capable of and that those who suggested that they where safe as the Airlocks would be Space Welded Shut don't know what they are talking about. :^0


Collapse -

So there is a 64 bit driver

by Michael Jay In reply to Michael

but you installed the 32 bit first?

If so there may be something stuck in the evil claw of the registry, perhaps searching the registry for cannon, assuming there are not any other cannon drivers could uncover something that the removal tool did not get.

Collapse -

RE: - So there is a 64 bit driver

by HAL 9000 Moderator In reply to So there is a 64 bit driv ...

No there is a Windows 7 Driver which I installed and it failed to correctly recognize the Scanner but it did install without any error messages. The Scanner is shown in Device Manager or Connected Devices with the Generic Error 28 Driver not installed. I also tried a Auto Update/Search but that also failed to return a working driver.

With other Scanners Canon has both 32 & 64 Bit Drivers but with this one they only list the Windows 7 Driver. Which is what I installed.

Also as there is a Canon IP4500 Printer involved deleting the Canon Entries in the Registry isn't really an option. But I did look there first.


Collapse -

Damned newbies

by santeewelding In reply to RE: - So there is a 64 bi ...

And their problems.

Collapse -

Yep I agree

by The Master2 In reply to Damned newbies

Damned Newbies.

Here I'm betting that this clown will never make another post or even return to see what has been suggested.

Collapse -


by santeewelding In reply to Anyone had any joy in get ...

Last refuge of scurrilous posters.

Related Discussions

Related Forums