General discussion

Locked

Apache problem

By brian ·
Hi,

I just upgraded to Apache 2.0.44 (from source) on a Caldera 3.1 Linux box. Installation went fine, however I no longer have a /etc/rc.d/init.d/httpd file to launch httpd. I did track down the /usr/local/apache2/apachectl file which appears to have the same function.

In other words, typing in "./apachectl start" will start the daemon. My problem is that I can't make it executable! I have tried every 'chmod' combination possible. I've tried chmod a+x and even that doesn't work. Itneeds to have the "./" in front of it.

Does this version NOT have the /etc/rc.d/init.d/httpd script? Why can't I make it executable?

Brian

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Apache problem

by cpfeiffe In reply to Apache problem

If you install apache source (instead of the package that is part of the OS install) it will not create a startup script for you. You have many options here. You can link the apachectl script to a startup script (ln -s /path/to/apache/bin/apachectl /etc/rc3.d/S50apachectl;ln -s /path/to/apache/bin/apachectl /etc/rc3.d/K50apachectl). If you do this you still have to fix your execution problem. Don't only check the permissions on the file, but check the permissions on the folders above it (/path/to/apache/bin) all the way to the file. Make sure the user you are trying to execute the file as (or all users) have read and execute access on the folders as will as the apachectl script. Another option is that you can simply copy apachectl to/etc/rc3.d/S50apachectl and /etc/rc3.d/K50apachectl and make the new files in /etc/rc3.d executable. There are many other ways to accomplish this task, but these are the two methods that are most common and you should be able to get one or the other to work for you.

Collapse -

Apache problem

by brian In reply to Apache problem

Poster rated this answer

Collapse -

Apache problem

by M.Mayberry In reply to Apache problem

The first answer is right about /etc/rc.d/init.d. If ./apachectl start or /usr/local/apache2/apachectl start works, then the file is executable. The reason that typing in just "apachectl start" won't work is because it's not in your path, that's whyyou have to use either "./" or the full path to apachectl. One way to work around this would be to create a symbolic link (ln -s) in either /bin, /usr/bin, or /usr/local/bin. You can check your path by using the "set" command (it works in RH 6.2, your mileage may vary).

Collapse -

Apache problem

by brian In reply to Apache problem

The path issue was the problem. Thanks.

Collapse -

Apache problem

by brian In reply to Apache problem

This question was closed by the author

Back to Linux Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums