Question

Locked

APIPA and 169.254.x.x

By blkshirt ·
So I have a little home network, nothing too complex. Two computers are wired into the router and I have laptops connecting wirelessly. One of the laptops would not connect to the internet. I checked and saw that the IP was set to 169.254.x.x. I knew this was APIPA. I decided to check to see if the wired ethernet would do the same thing (and it does).

I've done some searching on the internet and found this winsockxpfix file that I ran to no avail. I removed winsock and winsock2 out of the registry... nothing...

I know WHAT it is, but I'm just not sure how to fix it.

I've disabled the firewalls as well on the XP Home system.

Thanks in advance for any help...

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well I don't know if this will work now but

by HAL 9000 Moderator In reply to APIPA and 169.254.x.x

In the beginning I would have opened the CLI and typed in IPCONFIG /RELEASE then after that had finished typed in the following IPCONFIG /RENEW and that should have sorted the problem but since you've messed with the registry now it may need something more invasive to cure so you can try this

http://tinyurl.com/4y24g

I don't know if it will work but like everything make a copy of the Registry before you start to do anything and Backup all your Data as if you have to perform a clean install you'll want whatever data that was on this unit available when it's up & running again.

Col

Collapse -

I tried that as well...

by blkshirt In reply to Well I don't know if this ...

That was one of the first things I did before I jacked with the registry...

I'm thinking I may just have to backup data and reformat the HD and start fresh...

Collapse -

Since there are Manual Registry Changes now

by HAL 9000 Moderator In reply to I tried that as well...

I would tend to agree.

Col

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums