General discussion


Applications stealing focus

By acchini ·
Is there any way windows can be configured so that when applications are started they do not automatically steal the focus i.e make them stay minimised or in the background until wanted?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by ctrservices In reply to Applications stealing foc ...

Download Tweakui from

After installation, open Tweakui--expand the General tab and click Focus--put a check mark beside "Prevent applications from stealing focus"--click OK

If you still have the problem, click Start-- click Run, type regedit--OK--
HKEY_CURRENT_USER\Control Panel\Desktop--in the right pane, locate and then double-click ForegroundLockTimeout--under Base, click Decimal, type 0 in the Value data box--click OK--reboot.

Collapse -

by acchini In reply to

Poster rated this answer.
I already had TweakUI installed and configured to block applications stealing the focus but it wasn't stopping the problem. I tried the registry edit detailed and this hasn't helped either. The programs I seem to get the most problems with are AVG Antivirus when it is downloading updates and Symantec Winfax Pro when receiving faxes. I have searched the configuration settings for these but cannot find anything to stop them stealing the focus.

Collapse -

by ctrservices In reply to Applications stealing foc ...

Thanks for letting us know that you had two specific programs only which steal focus. The two programs make all the difference in the world as to what the suggested remedy will be. The more information you give us, the better we can diagnose without access to the machine.

AVG is allowed to take control at a system level. This means the previous advice won't work (hince the need for all information. Download the manual. It will explain how to turn off automatic updates (or change the time). Being at a system level, unless you change the time or turn the feature off, it will continue to do so.

Not familiar with the other program, but check its settings. It should have one to turn off this feature.

Related Discussions

Related Forums