ASA 55XX File upload from internal TFTP server

By seth.phillips ·
(Remote) -vpn-> internet <-vpn- (hub) TFTP Server

I am trying to access an internal TFTP server (via the tunnel) from the remote site to update the code on the remote ASA. I have tried both the ASDM and CLI. I get the following.

copy tftp://x.x.x.x/asa803-k8.bin flash

Address or name of remote host [x.x.x.x]?

Source filename [asa803-k8.bin]?

Destination filename [asa803-k8.bin]?

Accessing tftp://x.x.x.x/asa803-k8.bin...
WARNING: TFTP download incomplete!

%Error reading tftp://x.x.x.x/asa803-k8.bin (Unspecified Error)

The TFTP server is working correctly. It sends and receives other jobs. It appears that the tftp command is only sending the request to the the external interface. How do I get this to work?

I can ping back and forth and all hosts can see and be seen. I am going to be placing these in foreign countries and I cannot until this problem is licked.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

ASA 55XX File upload from internal TFTP server

by nel In reply to ASA 55XX File upload from ...

I just ran into the exact same problem as what you described, did you find a solution for the problem or did someone replied to you? Any help would be greatly appreciated

Collapse -

not enough resources on the tftp server

by jdrums In reply to ASA 55XX File upload from ...

I ran into this problem when tftp'ing from my laptop (running pumpkin tftp server) over the network. I had too many applications running. Once I closed some apps, it transferred successfully.

Collapse -

Disable wireless

by just4now88 In reply to ASA 55XX File upload from ...

I ran into this pronlem. In my case the ASA was not on the network. I connected my laptop to the ASA and put both on the same subnet. However, my wireless radio was on and no matter how many times I tried or TFTP software I used I kept getting the same error. Finally, I turned off (disabled) my wireless and it worked!

Collapse -

tell the ASA to use the inside interface

by _MuRf_ In reply to ASA 55XX File upload from ...

old post, still want people to have the info when searching...

config t
tftp-server inside "put tftp server IP here minus quotes" /
ASA(config)# copy tftp: disk0:
Address or name of remote host? "and again here"
Source filename []? asa825-26-k8.bin
Destination filename [asa825-26-k8.bin]?
Accessing tftp://x.x.x.x/asa825-26-k8.bin;int=inside...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!>snip

Related Discussions

Related Forums