Question

Locked

ASUS A8N-SLI Premium with IDE and SATA RAID will not boot

By gtwatson77459 ·
My SATA Nvidia controlled RAID array crashed and I am trying to do a restore from a Disaster Recovery CD (DR-CD). It had been booting fine from the SATA Raid1 array and I installed the IDE drive for a backup device and did a backup to it. After the SATA became unmirrored I screwed it up by going to BIOS and deleted it and the PC would not boot.

My DR-CD boots and does a temp install of XP but it sees the IDE drive as C: and the SATA Raid drive as and I installed XP to the partition. The problem comes when XP reboots, it does not boot from as I think it should but the C: IDE drive which has no boot files.

A long build up to a short question, how do I set up the BIOS to make the PC boot from the SATA RAID array and still be able to access the IDE drive? If I remove the IDE drive, everything works great and the PC boots from the temp XP and my backup software asks where the data file is located.

I have the Boot priority set to SATA as first and the IDE as 2nd, but if the IDE is installed it always tries to boot from the IDE. Is it possible to get this thing to boot from the SATA Raid array?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

WOOPS have been there....

by carlsf In reply to ASUS A8N-SLI Premium with ...

I Would suggest that you will ned the RAID setup disk and insert this to build the raid array again.

I had this happen and the RAID card need it's driver ti even reconize the card.

If you are running RAID 1 then you will/should have 2 x identical drives.
I hope this helps

Collapse -

Found out it can't be done

by gtwatson77459 In reply to WOOPS have been there....

I have researched the problem and if I put the IDE drive in the PC, it will always be C: no matter what I put in BIOS for a boot sequence. I can only boot from the RAID array if it is the only HDD in the PC. The catch-22 in this situation is that I can only restore the system if I can read the files on the IDE drive, but I can't boot the PC when the IDE drive is in the PC.

My solution is to install a 3rd SATA drive in the PC and use that for the backup drive. I "should" be able to boot the PC with only SATA drives in the PC and read the backup file to do the restore from the disaster recovery CD.

Collapse -

It sounds like you broke the "NO 2 Masters Rule"

by donaldcoe In reply to ASUS A8N-SLI Premium with ...

On any system, the controller config should be CD ROM, Primary HDD and floppy (thats if you still use floppy) On a motherboard with a RAID array you have 2 sets of controllers that offers a Master and a Slave side on each of: the IDE controller and the RAID controller. It sounds as if both are enabled, I suggest rejumpering your IDE drive to act as Slave and partition it as a logical drive. When the system boots there is an option key function that must be used to tell the system to access the RAID array. Then it should boot.

Hope this helps

Collapse -

Tried that too

by gtwatson77459 In reply to It sounds like you broke ...

I tried that. I set the jumper on the IDE HDD as Slave and tried to boot from the DR-CD. It starts to copy files and asks which partition to use. The IDE is C: and the SATA array is and if I choose when the PC reboots to continue the restore, it cannot find any OS because it automatically tries to reboot from C: even though I told it . I have put the 2 DVD drives on the primary IDE controller and the IDE HDD on the secondary controller and the same thing happens. From what I can find (by trial and mostly error), this Mobo will not boot from CD and install the temp winXP directory to the SATA array if there is a IDE HDD plugged in to the IDE controller. Everything works fine if the IDE HDD is not connected.

My solution was to get another SATA drive so I now have 3 in the PC. The first 2 are mirrored in a RAID1 array and the 3rd one is my backup storage drive. I am hoping that when I boot from the DR-CD, it will show up as and the SATA array will show up as C:.

Collapse -

I had virtually the same experience with my A8N32-SLI

by capt.brad In reply to ASUS A8N-SLI Premium with ...

I built the system with the nvidia RAID as drive C: and later added an IDE drive which I intended to use as a backup drive since I was running RAID 0. Regardless of how I set up the bios I could not make it work. The system insisted that the IDE was drive c: and the boot device. I finally gave up with that idea.

My board has a second RAID controller from Silicon Image, I purchased a SATA drive and ran into almost the indentical issue trying to use SI RAID to build a backup volume. It was lower on the chain of controllers and took precedence as c:.

The one thing that I didn't try was modifying the boot.ini file in an attempt force the nv Raid act as the windows partition.

Ironically I found a work around by adding the SATA backup drive to an open SATA port on the nv RAID controller. Without configuring the addition drive a part of the RAID array, the system views it as a regular drive and assigns a drive letter after c:. Works fine for purposes.

If you find any more satisfying solution to this issue I would be very interested in the details. Good luck!

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums