Question

Locked

ASUS motherboard problem with Linux - Kernel panic APIC

By steve ·
Hi

I have put together the hardware to build a Linux server but when trying to install Linux I get a warning message saying "Kernel panic - not syncing: IO-APIC + timer doesn't work! Try using the 'noapic kernel parameter".

I have googled this and there is a work around but it appears that this also has problems. There are some o/s's that will install (OpenSUSE, FreeBSD) but not the one I wish to use. I think this is because OpenSUSE uses a newer Kernel but I'm no expert so could well be wrong.

I would like to replace the ASUS M2n-XE motherboard but am unsure if this problem is across the whole ASUS range. Has anyone experienced this problem with other ASUS boards and can anyone recommend a good motherboard that doesn't have this problem.

Thanks
Steve

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well I'm unsure what is happening here

by OH Smeg In reply to ASUS motherboard problem ...

But it's likely to happen to any M'Board with that Chip Set so it should affect other brand M'Boards with he same Chip Set just as much as it's currently affecting this one.

Generally when you go about selecting parts for anything you look to see if there are any Known Problems with other Hardware or Software and then select the hardware accordingly.

Col

Collapse -

Hardware selection

by steve In reply to Well I'm unsure what is h ...

I did do a search to see if the board was compatible with Linux and what I read looked favorable. I obviously didn't search hard enough though. Is there a good place to check compatibility issues with Linux hardware.

One thing that I am unsure about is whether installing the o/s with "noapic" passed to the kernel at boot time will affect the long term reliability of the machine?

Collapse -

Well generally speaking the Users Forums

by OH Smeg In reply to Hardware selection

For your Flavor of Linux is the best place to start looking.

As I'm not a Open SUSE user I'm not at all sure where else to look for information on this particular problem but in answer to your question about noapic no it shouldn't have any major impact on the OS over time.

Though Novel do claim that they can have fixes available within 48 Hours for their Enterprise Offerings through IBM for Software issues like this so there may be something on their Users Forums from Novel about this.

Col

Collapse -

Flavour

by steve In reply to Well generally speaking t ...

I was planning on installing Debian and setting it up as a mail server. It is because of this that I am nervous of any error messages etc. and getting one before even installing the o/s was not helpful.

I had read in one forum that a server set up was proving unreliable due to the "noapic" causing errors due to irregular cycle times.

Being a relative newbie I don't know if this makes sense or not. All I am trying to achieve is to build a reliable, secure and low maintenance email server.

I have looked through the Debian forums and it seems a very common problem going back at least a year, apparently the reason no patch has been developed is due to the easy workaround ie: booting with "noapic". So if this still allows for a reliable system then I guess that is the answer....

Collapse -

Thanks

by steve In reply to Flavour

Thanks for your advice Col.

Collapse -

Steve Debian is a different Kettle of Fish to SUSE

by OH Smeg In reply to Thanks

You need to use this on Debian Installer because some hardware isn't supported by the Installer. SCSI HDD are a fairly common thing that require this on Servers.

I haven't tried Installing Debian on this type of setup so I'm not sure how well it installs but as the developers haven't provided any additional workaround it's a standard procedure to use this method.

As I'm in AU I went to bed for some sleep last night/early this morning and I'm now up for the next few days or at least that's how it feels.

Col

Collapse -

Try Fedora10

by sandeepmzc In reply to Well generally speaking t ...

Hi Steve ,
Me too had the same problem. I tried different operating systems, but the result was the same above mentioned error.
But Finally I was able to install FC10 in my box, so I suggest you to try the same,
Thanks & Regards,
Sandeep Sadanandan

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums