General discussion

Locked

ATI Radeon 9600 & XP

By MarkGibsonUK ·
I have a pc with an ATI Radeon 9600 128mb graphics card. Recently I upgraded the OS from XP home to XP pro and although the card must still be operating(the motherboard has no built in graphics) and everything appears normal, If I select display/properties/adapter the card is not mentioned and instead I have VGAsave or VGAsafe as the listed adapter. If I attempt to reload the drivers from the supplied cd I get an unsuccesful message recommending I setup the display adapter with a standard VGA driver before running setup. This is a major problem when I attempt to use software that requires the full power of the card. Any help would be gratefully recieved.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by wcp In reply to ATI Radeon 9600 & XP

Try uninstalling the ATI driver from "Add/Remove programs" and reinstall.

Collapse -

by MarkGibsonUK In reply to

I already have an they uninstalled no problem, It's reinstalling that is the problem

Collapse -

by TheChas In reply to ATI Radeon 9600 & XP

XP is running your video card in a "safe" mode.

What you need to do is select standard VGA as your video card.

First, forget about your ATI CD. The drivers on it are at least several months old.
Go to www.ati.com and download the latest Radeon driver for XP.

Next. open device manager.
Remove the VGAsafe adapter.
Close device manager.
Re-boot your PC, manually select standard VGA as your display adapter.

Re-boot your PC.
Install the driver that you downloaded.

Another option would be to run Windows Update. Skip Service Pack 2 at the moment. Carefully look at any driver updates to verify that they match your hardware.
Install selected driver and critical updates.

Oh, you may need to install DirectX 9C before installing the latest ATI driver.

Chas

Collapse -

by MarkGibsonUK In reply to

Sounds like I am heading in the right direction on that one but under device manager no display adapters are listed at all?

Collapse -

by cp7212 In reply to ATI Radeon 9600 & XP

I had a similar problem with a smaller ATI card. I could get it to uninstall, but re-installing it was impossible. I had to go into the registry and wipe all of the ATI keys. I went into HKEY Local Machine (HKLM)> Software and deleted the ATI Technology key and then searched (ctrl + F) for ATI values. Be careful and read, or even Google, anything you are unsure of. If you are unfamiliar with editing your registry, back it up first. Every time I installed it, then wanted to re-install it, I had to clean the registry of the values. Good luck.

Collapse -

by TheChas In reply to ATI Radeon 9600 & XP

Okay,

With no adapter listed at all, that explains a few things.

Run the new hardware wizard.
Choose to select from list, and choose a standard VGA adapter.

You might also be able to do this from Display Properties, Settings, Advanced.

Re-boot with the standard VGA adapter and you should be able to install the ATI drivers.

If that still does not work, download and install the AGP mini-port driver for your motherboard.

Chas

Collapse -

by MarkGibsonUK In reply to

Spot on with the motherboard driver Chas, thanks for the advice to all who replied, most appreciated.

Collapse -

by MarkGibsonUK In reply to ATI Radeon 9600 & XP

This question was closed by the author

Back to Desktop Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums