Audio Cd playback causes pc reboot...

By mferrusca ·
hello. i am experiencing this problem. at first all fingers pointed to winamp, since with this player, the pc booted immediately and everytime. i am using now windows media player, but the problem is back.

i have read that this behaviour could be cause by a dying power supply unit and that would make sense when i am playing a physical cd. but today i experienced a reboot while mounting an audio cd image with daemon tools and trying to play it thru windows media.

is audio cd playback quite demanding in terms of electrical power? i don't have this problem with dvds, so i wonder what could really be the problem.

pc is freshly formatted, 3GB ram, SP2 (i tried Sp3 and got into the infinite reboot blues, so i reformatted).

Update: i just booted my pc in debugging mode and drives playback perfectly. no instant reboot after i press play.

could this be a driver confict? what should i un/install?

any help and ideas will be greately appreciated.

thank you!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

The quickest way

by Jacky Howe In reply to Audio Cd playback causes ...

would be to try a known working power supply. You can also try this.

Click Start, right mouse click Computer and select Properties. Select Advanced System Properties, continue. Select Settings for Startup and Recovery. Untick Automatically Restart.

Minidump Files can be found here. C:\WINDOWS\Minidump\Mini******-**.dmp

How to read the small memory dump files that Windows creates for debugging

To download and install the Windows debugging tools, visit the following Microsoft Web site:

Instructions on using Windbg.

Open Windbg and select file, Symbol file path and brows to the Symbol folder that you have downloaded and installed Symbols to, select OK.

Close the workpage and save the Workspace information. This should lock in the Symbol path.

Open Windbg and select file and select Open Crash Dump then navigate to the minidump, highlight it and select Open.

There are two ways to use !analyze -v the easiest is to click on !analyze -v under Bugcheck Analysis.

When you have ran the initial dump if you look to the bottom of the screen you will see kd> to the right of that type in !analyze -v and press the Enter key.

Ctrl + a will let you copy the information and paste it into notepad.

Look to the bottom of the page for information like this. This was fixed by updating the Graphics Drivers.





PROCESS_NAME: logon.scr

LAST_CONTROL_TRANSFER: from 00000000 to bfef0fea

STACK_TEXT: f6434e6c 00000000 00000000 00000000 00000000 sgiul50!DrvBitBlt+0x585

STACK_COMMAN .thread 0xffffffff864f6a98 ; kb

FOLLOWUP_IP: sgiul50!DrvBitBlt+585 bfef0fea 75f9 jne sgiul50!DrvBitBlt+0x580 (bfef0fe5)


SYMBOL_NAME: sgiul50!DrvBitBlt+585


MODULE_NAME: sgiul50

IMAGE_NAME: sgiul50.dll


FAILURE_BUCKET_I 0xEA_IMAGE_sgiul50.dll_DATE_2001_08_18

BUCKET_I 0xEA_IMAGE_sgiul50.dll_DATE_2001_08_18

Collapse -


by mferrusca In reply to The quickest way

Thank you, Jacky. I will try it ASAP.

Collapse -

Let us know

by Jacky Howe In reply to Thorough!

how you get on.

Collapse -

Follow up...

by mferrusca In reply to Let us know

Jacky, i have several minidumps from quite a while. I guess this is a bit deeper than I thought.

I find dumps that blame different things, for instance:

BugCheck B8, {0, 0, 0, 0}

Probably caused by : ntoskrnl.exe ( nt!KeTerminateThread+5 )


BugCheck 100000D1, {0, 2, 8, 0}

*** WARNING: Unable to verify timestamp for sthda.sys
*** ERROR: Module load completed but symbols could not be loaded for sthda.sys
Probably caused by : sthda.sys ( sthda+1b340 )

BugCheck B8, {0, 0, 0, 0}

*** WARNING: Unable to verify timestamp for hal.dll
Unable to load image Dvd43.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for Dvd43.sys
*** ERROR: Module load completed but symbols could not be loaded for Dvd43.sys
*** WARNING: Unable to verify timestamp for CLASSPNP.SYS
Unable to load image cdrom.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for cdrom.sys
*** WARNING: Unable to verify timestamp for sptd.sys
*** ERROR: Module load completed but symbols could not be loaded for sptd.sys
*** WARNING: Unable to verify timestamp for atapi.sys
Probably caused by : Dvd43.sys ( Dvd43+2347 )

but mainly, (80% of them) this:
BugCheck 1000008E, {c0000005, ddd3a55b, bbd42570, 0}

Probably caused by : nv4_disp.dll ( nv4_disp!nvCelsiusTransfer+116b )

I have the /3GB switch enabled, so based on this results, I will run some tests with it disabled. I guess that when my graphics card/driver is called into action, the addressed space overflows or something to that effect, and the reboot takes place.

I actually only have 3 physical GB of RAM, so I might be wasting resources with the switch on (i set it to 2550, btw).

Hopefully, it's something related to that.

I will let you know.

Thanx again!

PS, btw, based on this, could i rule out the PSU? i'm still puzzled as to why only audio cds, and not dvds or mp3 playback, either emulated or thru physical media, cause the reboots.

Collapse -

A couple of suggestions

by Jacky Howe In reply to Follow up...

Are these all of the files that are giving you problems.

sthda.sys is an audio driver

Dvd43.sys file information

sptd.sys file information and then again

cdrom.sys belongs to the software Microsoft Windows Operating System or CD-ROM Driver. sfc /scannow would probably fix it.

nv4_disp.dll Is part of the nVidia display drivers

For a start I would try updating all of the drivers and disable the /3GB switch, I don't think that you need it.

It could be caused by Malware <a href="" target="_blank"><u>Malwarebytes</u></a>

It could also be a lack of pure current supplied from the power supply causing the hard drive file system to corrupt. Run a chkdsk /r

You can use the Hard Drive Makers Testing Utility to Test the Drive which can be downloaded from below.
<a href="" target="_blank"><u>Hitachi / IBM</u></a>
<a href="" target="_blank"><u>Western Digital</u></a>
<a href="" target="_blank"><u>Fujitsu</u></a>
<a href="" target="_blank"><u>Seagate</u></a>
<a href="" target="_blank"><u>Samsung</u></a>

Also check the Capacitors around the CPU for swelling or bulging.

Try another PSU as a faulty PSU can do major damage to the Motherboard.

Collapse -

Update the Video Drivers

by Jacky Howe In reply to A couple of suggestions
Collapse -

Solved... apparently.

by mferrusca In reply to Update the Video Drivers

Well, I was working with the latest Nvidia drivers but I decided to wipe them clean and install the OEM drivers from my PC recovery cd and I can report i am playing audio cds now. No strange behaviour.

If I need to, I will upgrade video drivers with the same producedure: wipe previous drivers, install new ones.

Hope I am not jumping the gun here, but possibly the problem was solved.

Thanx Jacky. I learned a LOT with your assistance.


All the best!

Collapse -

better get to it...

by mferrusca In reply to A couple of suggestions

I got a lot of things to check and recheck, Jacky.

I'll be back with an update as soon as possible.

In the meantime, I GREATELY appreciate all the help you have been provinding me.

Amazing knowledge!!!



Collapse -

Let's hope that

by Jacky Howe In reply to A couple of suggestions

the problem is solved.

Related Discussions

Related Forums