General discussion

Locked

Audio for DOS game choppy

By JustMe2007 ·
I've just got windows XP and I've got an old DOS game I really like, but the audio is choppy. The game is Conquest of the New World Deluxe Edition by Interplay. The sound card I have is Intel Integrated. To set up sound in the game, I must manually choose my sound card. My card is not on the list, but when I choose Sound Blaster Pro, I get sound. That sound is choppy and it slows down the game. The game has worked on a different computer with windows ME before. Just ask if you need more information.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Audio for DOS game choppy

by Mike (from Canada) In reply to Audio for DOS game choppy

try adding more ram or get a faster cpu. Slower computers tend to have more choppy-sounding games. If your memory is used up, you will hear the hard drive go and what the cpu is doing is activating the hard drive then playing sound and continues to behave that way because the hard drive is considered virtual memory.

Collapse -

Audio for DOS game choppy

by JustMe2007 In reply to Audio for DOS game choppy

I have got 900 Mhz celron processor and 384MB RAM. That is better (in both ways) than every other computer that has run the game.

Collapse -

Audio for DOS game choppy

by OTL In reply to Audio for DOS game choppy

Had the same problem with ESS1888 would run on sound blaster pro but not on synthesiser (ESS). Have you tried other sound card types? Check where your audio is set (port, irq settings).

The other computer probably had a sound card on the list?

Collapse -

Audio for DOS game choppy

by JustMe2007 In reply to Audio for DOS game choppy

I have tried other types of sound cards. With those cards the sound doesn't play. I also checked audio settings. The only setting I could find was IRQ and it was 17. 17 wasn't an option in the game sound settings. I also tried various IRQ settings. That just may the sound not work.

The other computer's sound card was not listed either. When I chose sound blaster, it worked.

Collapse -

Audio for DOS game choppy

by Blackcurrant In reply to Audio for DOS game choppy

Hi there

I have not yet even seen XP, but I assume you have the option to configure a shortcut that runs an MS-DOS program. If you do then you you may be able to define your own autoexec.bat as you can in W9x. Try the following:

Open device manager, select your sound card and click on properties. write down the I/O range, interrupt and DMA channel info. Using this info you can add the line:
SET BLASTER= a220 i5 d1 h5 p330 t3
Where: a220=first I/O address; i5=interrupt 5; d1=DMA channel 1 for 8bit I/O (the first channel); h5=DMA channel 5 for 16bit I/O (the second channel); t3=card type (normally irrelevant).

Good luck

Collapse -

Audio for DOS game choppy

by JustMe2007 In reply to Audio for DOS game choppy

Tried it and the sound was still choppy. I tried many different settings. I have a feeling that my sound card is just not very good at emulating Sound Blaster. Just ask if you need more info. :)

Collapse -

Audio for DOS game choppy

by JustMe2007 In reply to Audio for DOS game choppy

This question was closed by the author

Back to Windows Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums