General discussion

Locked

Automatic Update Greyed Out

By trtjj ·
We would like to turn off Automatic Updates from all of our workstations but the buttons are all greyed out. We have some legacy aps that do not work with sp2 and we are not installing it. The problem is that the we do not want the users to know that "updates are ready to install" especially since they do not have admin rights. We can not change the settings and we are not running SUS. Any help will be appreciated.

Thanks!

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Automatic updates greyed out

by smanches In reply to Automatic Update Greyed O ...

You need to log into the pc's as a local administrator to be able to make the changes to those configurations. Or if there is a group policy in effect on the network, you may need to log into those pcs as a network admin. We have wrote a group policy to stop automatic updates on all our pcs in our network (approx. 300 - 400) with successful results. Hope this helps. :-)

Collapse -

Tried Local Admin

by trtjj In reply to Automatic updates greyed ...

Hi,

I've also tried to change it as the local admin, network admin and looked over the Group Policies. I may be missing something. I am actually brand new to this environment and may hae missed something.
Thanks

Collapse -

Services

by dafe2 In reply to Automatic updates greyed ...

Use Group Policy to Dissable automatic update services.

Collapse -

Automatic Update Greyed Out

by umesh_mishra84 In reply to Automatic Update Greyed O ...

1) Make sure that the Automatic updates and the BITS service in the services.msc
window are set to automatic and are started .

2) Check the registry key for permissions

1.Click Start, Run and type REGEDIT
2.Navigate to this location: HKEY_LOCAL_MACHINE \ SOFTWARE \ Policies \ Microsoft \
Windows \ WindowsUpdate \ AU
In the right-pane, look for a value called NoAutoUpdate
Check for its value, if the value is set to 1, then right click on NoAutoupdates
and select modify and change the value to 0 and click ok
Close the registry editor and restart the computer Then open system properties and
check the Automatic Update options it will be enabled

Collapse -

Regedit - Allow local admin to choose AU policy

by a04081999 In reply to Automatic Update Greyed O ...

HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\AUOptions

1 - Disable Automatic Updates
2 - Notify for download and notify for install
3 - Auto download and notify for install
4 - Auto download and schedule the install
5 - Allow Local Admin to Choose << Pick me!

Collapse -

Thanks - this resolved it for me

by Steve@CP In reply to Regedit - Allow local adm ...

Thanks, exactly what I needed as I had tried as local admin, added my ad user to local admin, of which neither worked.

But this did, again thanks, much appreciated, Steve

Collapse -

Check it out Hope it will solve your problem

by manishmishramcp In reply to Automatic Update Greyed O ...

Symptom
When you open the Automatic Updates tab in My Computer Property sheet, or from Control Panel, all of the Automatic Updates configuration options may be grayed out. This happens due to any of the following reasons:

You're not logged on as Administrator (or equivalent)

Automatic Updates Policy is enabled

Automatic Updates (and Windows Update) access is blocked via Group Policy

Resolution
To make the Automatic Updates options configurable by the user (only for stand-alone systems), remove the restrictions 2 & 3 above.

Click Start, Run and type REGEDIT.EXE

Navigate to this location:

HKEY_LOCAL_MACHINE \ SOFTWARE \ Policies \ Microsoft \ Windows \ WindowsUpdate \ AU

In the right-pane, delete the two values AUOptions and NoAutoUpdate

Navigate to this location:

HKEY_CURRENT_USER \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ WindowsUpdate

In the right-pane, delete the value DisableWindowsUpdateAccess

Using the Group Policy Editor - for Windows XP Professional

Click Start, Run and type gpedit.msc

Navigate to the following location:

=> Computer Configuration
==> Administrative Templates
===> Windows Components
====> Windows Update

In the right-pane, double-click Configure Automatic Updates and set it to Not Configured

Then, navigate to this location:

=> User Configuration
==> Administrative Templates
===> Windows Components
====> Windows Update

In the right-pane, set Remove access to all Windows Update features to Not Configured

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Forums