General discussion

Locked

Bad RAM ??

By cblgy ·
Hi - question about RAM

just intstalled an extra 256mb of ram in a
p3 566 celeron. Ram was 133mhz (old was 100mhz)
Wouldn't boot - no beeps - just bios?
after removing the new dimm - hard drive physical failure! Can boot from a floppy or Cdrom - checked all cables - switched cables - switched from primary to secondary - nothing!
Can boot from floppy and system is fine.
Tried again with new RAM - nothing - but with only old RAM - boot from floppy
Can Bad RAM possibly affect the hard drive?
or is this just the craziest coincidence ever?
P3 celeron 566 - seagate 8.4gb drive

thanks in advance
Carman

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by tech_wiz03 In reply to Bad RAM ??

Bad Ram usually will not effect Hdd, however, re your ram problem. NEVER ! mix 100MHz Ram with 133MHz ram.
1) the FSB (Frontside buss ) is set to ram access speed on most mbo's. ( motherboards) so if you mix 133MHz and 100MHz you end up with two different access times.
2) when changing ram especially near the cpu and hdd header connections it is easy to crack the mbo causing unpredictable problems. Be careful never to force the ram into the sockets, also it is best to support the unside of the board during insertion.
3) You can check the new ram by swapping it for existing ram and configuring the mbo for the new ram speed. Ie: remove old ram, insert new ram, set FSB to new ram speed and see if PC boots at least to where bios screen appears.
4) As for HDD check the bios settings and make sure the HDD is being recognized right.

regards
rick

Collapse -

by Oz_Media In reply to Bad RAM ??

Well the FSB is definitely A problem but, in my experience, adding faster RAM is usually OK but it will slow to the installed clock speed of 100MhZ and not operate at its full 133.

A question, you mentioned you ADDED 256MB, how much did you have before?
What OS are you running?

Win98 doen't like more than 384 MB's, 512 will cause problems.

If your OS can handle the RAM can you MOBO?

Is your processor clock speed correct?

Do you have a BIOS update to support the amount of RAM you have?

If you provide more info it may be easier to diagnose. This is Chas's specialty actually, hopefully he'll be by to offer some more ideas.

I think you should investigate your system some more to see what your processor and mobo can support.

Collapse -

by Oz_Media In reply to

Lastly, is your processor a PIII or a Celeron with a 256 split level cache to emulate a P3?

Collapse -

by TheChas In reply to Bad RAM ??

There should be no problem mixing PC 100 and PC 133 SDRAM.
However, some of the new PC 133 SDRAM modules use quad density RAM chips. Mixing RAM density can cause problems.
Some motherboards even need specific technology SDRAM.

It may be a coincidence that your HDD failed when you installed the RAM module.

However, assuming that you are in the northern hemisphere, it is more likely that you had a static electricity discharge to the inside of the case when you were installing the RAM.

It is "best practice" to properly ground yourself with an ESD wrist strap before even opening the case on a PC.

Static electricity can cause damage to electronics components at voltages well below the level where you would feel or see a static shock.

Chas

Collapse -

by w2ktechman In reply to Bad RAM ??

You mention that the system runs fine when booted to a floppy disk. You may have accidentally erased the boot sector (I have done this before when removing and replacing HDD's before). Static is the key. Anyway, if the hard drive works fine after booting to a floppy, try FDISK /MBR and then SYS the drive. This should fix it.

Back to Hardware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums