General discussion

Locked

Baffling Worktstaion DHCP Problem

By szymonik ·
Here is my configuration:

I have a Motorola cable modem at 192.168.100.1

I have a Netgear router at 192.168.0.1, which is also the DHCP server.

I have four workstations, all running XP Pro SP2, all fully patched with the very latest drivers, all hard wired Ethernet 10/100.

I have a DHCP range of 192.168.0.2-192.168.0.100

No matter what I try, one of the workstations refuses to acknowledge the Netgear router, and insists on connecting to the Internet through the cable modem instead. It always gets an IP of 192.168.100.x, and then can't PING the rest of the PCs on the network or join the assigned workgroup.

This PC is hard wired to the router, just as every other PC is.

I've tried clearing and refreshing the IP settings using IPCONFIG. If I try and assign an IP in the 192.168.0.x range, it refuses to connect to the network at all.

So I can either have this PC use 192.168.100.x through the cable modem and connect to the Internet, or hard code it to 192.168.0.x and it can't connect to anything.

I'm baffled.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to Baffling Worktstaion DHCP ...

It is baffling in that your DHCP is trying to assign an IP address that is not in the same scope. If you set a static IP address for the comp in the same range and subnet mask as the 192.168.0 address assigned by the routers DHCP server [you get these values from the router]. You'll also need to make a reservation for it in your routers DHCP server [they should have an area where you can do this]. Then you need to specify the default gateway address [the routers IP address,[not the address assigned by your ISP] and DNS addresses that your ISP assigns. Then the comp should be able to see all others on the LAN and have internet access via the router.

I would look for a firmware upgrade on the routers mfg web site. Sounds like a firmware bug.

Collapse -

by oskiller In reply to Baffling Worktstaion DHCP ...

Have you tried replacing the NIC? While I have not seen the exact situation, I have seen similar situations before. I once had a 3COM NIC that would not work with DHCP or BOOTP, but would only work with a hard coded address no matter what we tried and what system we put it in. Put in a replacement and it worked like a champ.

Collapse -

by p.j.hutchison In reply to Baffling Worktstaion DHCP ...

Try resetting the TCPIP settings using:
netsh winsock reset

Collapse -

by wlbowers In reply to Baffling Worktstaion DHCP ...

Your cable modem should be connected to the router, then the router should feed the switch or have the switch built in.

The router should be the assigned gateway for all computers.

How can the computer get to the modem without going through the router?

Is the modem some how connected behind the router.

Lee

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums