Bios not recognizing 40g HD

By pkthewall ·
I have a Sony Vaio desktop. I have a 40g Western Digital HD installed as Master and 2 CD-Roms. The Bios sees the Cd-roms, but not the HD. When i try to install Windows XP, it can not continue because it tells me that no HD are installed.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: Bios not recognizing 40g HD

by ameack In reply to Bios not recognizing 40g ...

Does the Bios sees both the CD-Roms?

If so you got to make sure that you have used the jumpers at the back of the HDD and CD-ROM.
Make sure HDD is set to Master and CD- ROM on Slave. Or leave it on Cable Select.

2nd option
Why do you need 2 Cd-Rom's
Try installing O/S connecting HDD and 1 Cd- ROM and then later on you can install 2 Cd-ROM's.
try it

Collapse -

Drive Jumper Settings

by TheChas In reply to Bios not recognizing 40g ...

On the presumption that your Western Digital is on 1 IDE cable and your 2 optical drives are on another IDE cable, the most likely problem is wrong jumper settings on the WD.

Western Digital drives MUST be specifically jumpered as a single when there is only 1 drive present. As the normal single drive setting is the same as cable select, make sure that the IDE cable is not a cable select type, and / or that the drive is connected as the Master.

If the jumpers are correct, and you have tried a new cable, then there is a good chance that the controller on the hard drive is bad.


Collapse -

Jumper settings

by pkthewall In reply to Drive Jumper Settings

I've tried every jumper setting. I would generally agree that it might be a bad controller on the HDD. I've tried 3 different drives with no success.I've used different cables. The Cdroms are on their own plug on the motherboard. The computer is a Sony Vaio with an Award Bios. The system was running good until I decided to add a bigger HDD. I tried 2 Western Digital and 1 Seagate The Cdroms are factory installed.

Collapse -

Did you

by santeewelding In reply to Jumper settings

Sneeze on the board while you were in there?

Collapse -

40GB is bigger than what

by Who Am I Really In reply to Jumper settings

what size was the old disk?

you didn't specify the age of the system
but if we're talking P1 - early P2
then we're also probably talking about an 8 - 32GB HDD size limit,
which is a programmed BIOS Limitation and possibly a controller issue also,
as the 28-bit LBA in the late P2 through the early P4 systems are able to use 127GB HDDs

and some BIOS setups will refuse any drive that identifies itself as larger than the max. size it can address.

Collapse -

Prior HDD size

by pkthewall In reply to 40GB is bigger than what

Thee was a similar size HDD in prior. The computer was built w/a 40g HDD. I think I installed a disk that had a virus. The system won't recognize any so far except an old Maxtor with about 2 gigs. Like I said, the system came with a 40g Western Digital HDD. the controller is built into the motherboard. There is no removable controller card.

Collapse -

Controller - BIOS. . .

by Who Am I Really In reply to Prior HDD size

A virus won't toast a controller
a disk of a different size than what's specified in the BIOS can fry a controller

that happened to me once
I had an Add-On Multi-I/O Card fry when I added a Disk
because I didn't immediately change the HDD info in the BIOS setup
the disk appeared to work but only once, as it totally fried the controller because the info in the BIOS was for a different disk size than the one I had just installed.

the next time I booted the system nothing was there

the other thing that might be worth mentioning is the original HDD might have had a DDO (Dynamic Drive Overlay) which allows a larger disk to be used on a system with BIOS limit smaller than the disks actual capacity,
ie. installing a 20GB HDD on a BIOS with only 8.4GB capability requires a DDO

if you erased the original disk after or before removing it and it had a DDO that could be one possibility

just taking stabs in the dark as I don't know your system spec. or its age etc.

Collapse -

BIOS Settings

by TheChas In reply to Bios not recognizing 40g ...

Is the BIOS setting for the Primary drive set to Auto-Detect?

Another thing, check and verify that the drive spins up and runs it's POST at power on. You should be able to hear or feel the drive spin up and perform a short seek function.


Collapse -

Have you tried booting with

by Kenone In reply to BIOS Settings

No jumpers on the drive??

Collapse -

Jumper, Controller

by pkthewall In reply to Have you tried booting wi ...

I've tried no jumpers, and I don't use a card. HDD plugs into motherboard. HDD does run during system boot. I can put in a smaller drive without any problesm. Again, system came with a 40g HDD.

Related Discussions

Related Forums