BIOS not releasing all memory

I purchased a new mobo, cpu, and memory (2x4=8 GB). I have a 1 TB hard drive, split into two equal partitions. There are two operating systems installed, one on each partition; Windows 7 Pro, and Windows Server 2012. Both are 64 bit OS's.

The operating systems installed without any problem. During the boot, I can select either OS.

The 'system' information on both OS's show that they are the 64 bit versions.

However, here is the problem. Both OS's show that 8 GB of memory is installed, but only 3.75 is available.

I understand that part of the memory is used for the onboard video. I have adjusted that within the BIOS and the available memory changes from 3.48 to 3.75. All depending upon where it is set, the available memory will adjust slightly, based upon how much memory is allocated for the video.

The memory is two sticks of Kingston HyperX FURY 4GB 1600MHz DDR3. I have tried placing the sticks in different slots; 1-3, 2-4, 1-2, 3-4. The only combinations that work are 1-3 and 2-4. The others give only a blank screen.

From all of my testing, the problem appears that the Mobo thinks the OS's are 32 bit, and only releasing half of the memory because of that.

I've tried adjusting the settings in MSCONFIG > BOOT > Advanced Options. None of the setting makes any difference.

Anyone else experienced this problem?

Anyone have a solution? I would appreciate any help. Thanks in advance.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Share your knowledge

Related Discussions

Related Forums