Question

Locked

bios problem

By odiebugs ·
Anyone know why after a windows system hang,that
my boot device priority would change in the bios. m2n-sli running 2 raptors /not raid, one for os and other extra drive. After a sys hang they get switched in the bios and then I get the no boot error because it tries to boot from extra drive. Each time I have to go to boot priority in bios and switch the os drive, to first and extra second.

The system hangs are from running games, that are xp based on vista.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

SATA?

by LarryD4 In reply to bios problem

They are SATA drives right?

Collapse -

Yes

by odiebugs In reply to bios problem

Both drives are internal sata

Collapse -

Hmm

by LarryD4 In reply to bios problem

One idea...
Could it be the MB battery?

But let me ask this, what would happen if you were to leave it the way it is when it switches? If we leave the bios the way it wants to be and physically switch the HD cables to make it work. Would it stay or would it then switch them again?

Collapse -

Also check the function of the Boot Drive

by OH Smeg In reply to Hmm

With the WD HDD Testing Utility.

http://support.wdc.com/product/download.asp?groupid=612&sid=2&lang=en

It could be in the process of failing.

Col

Collapse -

thank you both

by odiebugs In reply to bios problem

Larry; will give it a try,good idea.

oh smeg, The first thing I did was run two
western dig diag and windows error and repair sector, but all came back ok, weird.

Collapse -

OK now I'm clutching at straws

by OH Smeg In reply to thank you both

Boot the system and look at the Drives in Device Manager. Make sure that the Boot Drive is set to Active. If it isn't that could be the problem here. Normally you don't need to bother with SATA drives the System picks up the Boot Drive and it can be o any of the SATA Connectors on the M'Board.

Only thing I can think of here is that something changes the Boot Drives Settings. If that is what has happened you can use the Ultimate Boot CD to reset the Boot Drive.

http://www.ultimatebootcd.com/download.html

Col

Collapse -

I've always had success

by Jacky Howe In reply to bios problem

with Sata drives if the Boot drive is on the lowest numberd Sata slot. Some boards start at slot0 and others start at slot1.

< edit to add .

Try running chkdsk c:/r from a command prompt.

Collapse -

did it -oh sm-larry -jacky

by odiebugs In reply to bios problem

I tried switching cables, but the bios see'e
the hd not the port. TY

Both active and show as local. TY

As long as the os drive is listed as 1 boot I have no problems. When I run ckdisk I always use command, because it runs admin rights and vista is a pain.


I have no problems booting, the main thing is when I get a system hang and try to reboot
the boot priority gets changed and it tyies to boot from my second hd which is just for storage and does not have a os no duel boot.

Thanks to all of you for the help and your time, I am going to try the new bios update,
now im running 1405,maybe its the bios itself.

Collapse -

A couple of thoughts along with the BIOS update

by Jacky Howe In reply to did it -oh sm-larry -jack ...

Is there an Active Partition on the second drive, it may be confusing the BIOS.
<br>
Open up a command prompt, and type in these commands and press Enter as you go<br>
diskpart<br>
select disk 1<br>
list partition<br>
inactive
<br><br>
Reboot the system. Open System Restore and stop monitoring that drive.
<br><br>
Boot from the Vista DVD and see if it will automatically detect any problems with the startup.
<br><br>
<i>Keep us informed as to your progress if you require further assistance.
</i>

Related Discussions

Related Forums