General discussion


Boot from IDE instead of SATA - again

By Blackcurrant ·

I have an identical problem to that solved here:

This time I have just upgraded from Norton system Works 2004 to NSW 2005. My machine is a Dell Optiplex GX270. It contains two IDE drives and 1 SATA drive. My OS is WinXP Pro SP2

I installed GoBack as follows - first I uninstalled GoBack 2004 then rebooted. Next, I disabled all non Microsoft services and disabled all startup items using msconfig. I did not disable the Intel services nor the ATI services (my computer would not boot at all until I renabled the ATI services in Safe Mode), nor the Dell iap service.

I next rebooted and installed GoBack. I noticed that when GoBack was being installed, it created a gobackio.bin file on my C: drive (IDE primary master) and my F: drive (the SATA drive). After the first reboot, the GoBack screen appeared, then the boot process continued, only to immediately stop. I got a black screen with the message 'strike F1 to retry boot, F2 for setup utility'. Pressing F1 returns to the message, and pressing F2 causes the computer to lockup.

I assume the computer is attempting to boot from my SATA drive, as when I reboot, press F12 and choose 'Primary Master' (my C: drive), from the list of available boot devices, the GoBack screen appears, and the computer boots normally. Also, if I disable GoBack and reboot, GoBack saya it is removing the GoBack history from the C: drive, and then the computer boots normally from my primary master C: drive. Re-enabling GoBack, returns me to the error message.

Therefore, it seems to me that when GoBack installed the file on my F: drive it has somehow caused it to become 'live' again. When I look at the F: drive in Disk Management, the F: drive is not marked as active.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
Thread display: Collapse - | Expand +

All Comments

Collapse -

by Blackcurrant In reply to Boot from IDE instead of ...

This problem was previously solved by completely removing the partition from the F: drive and rebooting without reallocating the unpartitioned space. That is not an option this time. I have thought about renaming the gobackio.bin file on the SATA drive, but do not know how this will affect booting the computer. I wish there was an option to remove GoBack from a particular drive rather than just a blanket uninstall!

If anyone can help I will be very grateful.

Collapse -

by Blackcurrant In reply to Boot from IDE instead of ...

Have just renamed the gobackio.bin file (with GoBack disabled) , to gobackio.old, re-enabled GoBack, the computer rebooted and same problem - strike F1 to retry boot - When GoBack was re-enabled it just created a new gobackio.bin.

Collapse -

by willcomp In reply to Boot from IDE instead of ...

I'm not familar with all the nuances of GoBack, but do know that it modifies MBR. That may be what is causing SATA drive to appear bootable.

Drives with GoBack cannot be read when connected to another PC. For that reason, I have learned to despise GoBack. I fix PCs and it is difficult, if not impossible, to recover info from a drive with hosed GoBack installation.

May want to try using fixmbr on SATA drive (there's obviously a risk of data loss here).


Collapse -

by Blackcurrant In reply to

Thanks for answering

Collapse -

by d'solve IT In reply to Boot from IDE instead of ...


I edit and modify the boot.ini to make requisite changes to reflect the correct boot partition/drive.

I never use any 3rd part software (unless it is absolutely imperative) and I agree with Willcomp's view here.

You could rename the boot.ini file on your SATA drive and edit the boot.ini on your IDE primary drive. Check to see if you have something similiar to this example below:

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn

N.B. the boot.ini is on the root of your boot drives. Since you are not able to even get to a prompt (leave alone a GUI), you could take the drives to another computer and do the edits there.

Good Luck

Collapse -

by d'solve IT In reply to

Note: The line after [operating systems] is on a single line - no carriage return/line feed.

Collapse -

by Blackcurrant In reply to

Thanks for answering

Collapse -

by Blackcurrant In reply to Boot from IDE instead of ...

Thanks for the answers. Thanks especially for the advice Willcomp, I now have GoBack installed just on my C: drive. The weird thing is that there is no boot.ini on the SATA drive - there are no OS system files on it at all, apart from the hidden Recycler and System Volume Information folders, which at present are empty.

The solution was to uninstall GoBack, then disable my SATA drive in the BIOS, then reinstall GoBack. I had tried this initially and had re-enabled the SATA drive after the first reboot, and the machine booted as it should until I ran LiveUpdate. LiveUpdate downloaded a major update to GoBack which required GoBack to be uninstalled then updated, which I did. However, during upgrading it copied a new gobackio.bin to the SATA drive.

So, to summarise, I have had to disable the SATA drive until the uninstallation, reinstallation and upgrade were complete, hiding the drive from GoBack. I have now re-enabled the drive and my computer boots as it should.

What makes me mad, is that although there is an option to do a custom install of GoBack, it would not allow me to install GoBack on just the C: drive, it had to have at least 10MB of files on the SATA drive as well. This has been a frustrating experience. But, if I had not had this problem and had suffered a major SATA disk crash, it looks as though I would have lost my data. This is now less likely to happen.

Thanks again for your help

Collapse -

by Blackcurrant In reply to Boot from IDE instead of ...

This question was closed by the author

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums