Browser Focus

By Kiltie ·
One that has always puzzled me, so this question is mere curiosity.

Sometimes, using IE6 as an example, opening a link that needs a browser results in one of 3 positive actions:

1. Opens a new window
2. Uses the existing open window.
3. Steals any window it can find (apparently at random)

so the question is, how do you control this behaviour?

Particularly in option 3 above, it is quite annoying.

In Firefox, for example, you can right click and chose whether to open in a new window or a new tab.

btw IE7 doesn't enter into the equation at all, since it is not available for everyone, this question applies to mundane useage on ordinary computers running Windows.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

This is controlled by...

by TechExec2 In reply to Browser Focus

This is controlled by JavaScript code in the web page, and by browser options/behavior:

- If there is no JavaScript in the link, it opens in the same window/tab.

- If the JavaScript in the link does not specify which window to open in, it opens in the same window/tab.

- If the JavaScript specifies _BLANK as the window name, it opens a new window.

- If the JavaScript specifies a specific window name, the page opens in that specific window if available, else a new window.

- Firefox has an option to direct new window openings to a new tab instead. This overrides the JavaScript.

Collapse -


by Kiltie In reply to This is controlled by...

Doesn't help me be in control, but I'll give you a "Thumbs Up" for your reply

GRRRR @ hidden Java

Collapse -

IE6 Fix

by tfsimpkins In reply to Browser Focus

I don't know if I've ever noticed this problem because I open a new window everytime and type in all of my URL's. A simple way to fix this is to open Internet Explorer, go to Tools, then Internet Options. Click on the Advanced Tab and Scroll down untill you come to the "Browsing" settings. Locate the "Reuse windows for launching shortcuts" setting and uncheck that box. Click Apply, then OK. Then you're all set. If that doesn't work then blaim JAVA. :)

Related Discussions

Related Forums