General discussion

Locked

Browsing local print shares using server alias produces login prompt

By mushu ·
Having a weird problem and because no specific error message is produced I am having trouble searching for its answer. Any help is appreciated.

I have a 2003 print server that has an alias in DNS. Alias works great (DisableStrictNameChecking and OptionalNames reg keys have been added). When I browse the print resources from an different computer I see all the print queues. (e.g. Start > Run > \\Aliasname ) However, when I follow these steps from the server hosting the shares I am presented with a login prompt. The print shares are open so no authentication is required. For grins, I've tried authenticating but no account works. I can browse the shares from the local box using Start > Run > \\Servername though. Also, pinging the aliasname from the server works - but it is getting that info from DNS. I've added an entry in the hostfile also but still no luck.

Any suggestions appreciated.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

NTFS Permissions

by BFilmFan In reply to Browsing local print shar ...

What security groups are being granted access on the NTFS permissions?

Collapse -

by mushu In reply to NTFS Permissions

Thanks for the reply. These are "unsecured" print queues so Authenticated Users have access to view/use them.

I am logged in with an admin account on the server when this happens and using the server name produces a list of print queues while using the alias produces the login prompt.

Collapse -

same issue

by nicolas.wagner In reply to Browsing local print shar ...

Hello, Ihave the same weird problem with shared ressource on a windows2003 server. I also inserted the same registry keys and populated the host file.
Did you find any solution???

Collapse -

Same issue, as well...

by wumarkus In reply to Browsing local print shar ...

I am having the same issue and it is a major operational issue for us right now. I have tried the same steps and also tried modifying all sorts of different security policies. Has anyone found a solution yet? The one thing I notice is an event ID 537 with logon type 3 and garbled characters in the logon process field. It seems to be using NTLM authentication when using the alias rather than kerberos. Not sure what the deal is here, since I've made this work in the past...

Collapse -

Same problem

by daniel.meier In reply to Browsing local print shar ...

I've got the same problem on all 2003 Servers. Any solutions?

Collapse -

Got the solution

by daniel.meier In reply to Browsing local print shar ...

i spent over 6 hours for searching the internet and found the same problem on a lot of pages, without any solution. We already had the reg key
Disablestrictnamecheck but it allowes only to access the shares true alias from remote computers, but not localy.

I tried several stuff in our lab and the needed key to allow local shares to be opened true alias name:

DisableLoopbackCheck=1

see http://support.microsoft.com/?kbid=896861 for details

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums