Question

Locked

Can you help me on why my maxtor 3200 won't read on my lab top or pc?

By tek-12's ·
When I plug my maxtor 3200 external hard drive to my labtop or my pc using the usb port neither one reads as a plug n play. I?ve tried everything and can?t figure out why its not working.

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

A common failure...

by Kingbackwards In reply to Can you help me on why my ...

There are three common failures:

1. The drive was shaken or dropped (intentionally or not) to the point where it may have broken the drive and wont be recoverable.

Detectable by the drive clicking or not spinning up when plugged in.

Confirm by taking it out of the enclosure and putting inside the machine to see if the data is still there. If not, this was the failure

2. The Power supply failed.

Detectable if it doesn't look like its powering up when plugged in or may light up but just not register when connected.

Confirm by using a different power supply. If it works correctly with a new power supply, this was the failure.

3. The USB/Firewire Connector or Chip is broken or dead.

Detectable if the cable feels loose, makes partial connections or doesn't register when usb plugs in, but works with firewire plug (or vise versa).

Confirm by using another cable, port or enclose.

The last two can be worked around if you take out the drive from its enclosure and put it inside a desktop or another enclosure that isn't broken.

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums