General discussion

Locked

cannot access share

By sandm4n ·
I am having some problems with a windows 2003 server and share. I cant seem to access the share via the use of \\servername\share. I can however get to the share by the use of the IP address. Now I know most of you will think DNS but this isn't the problem. I know this for a fact as I have alredy gone down that road. I can access shares on other servers on the network with \\servername\sharename

Problem seems to be with just this one server. Role of server is SQL and doesn't do anyting else but this. It is part of our domain and I have run anti virus on this. netshare command shows all the shares available.

This server is named server-name. Note the "-" in the name. Not sure if this is the problem with 2003. Server was originally setup by someone else and apparently the shares were working.

Has anyone come across this before?

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

some suggestions

by j3nn333 In reply to cannot access share

These are the commands that we run as a standard on all of our iSCSI deployments:

sc.exe config msiscsi depend= dmserver
(Ensures the Microsoft iSCSI LUN drives come online and are ready to be used).

iscsicli bindpersistentvolumes
(Used with the above to ensure that Microsoft iSCSI LUN drives come online and are ready to be used.)

sc.exe config lanmanserver depend= msiscsi
(Ensures the network shares come online.)

sc.exe config lanmanworkstation depend= msiscsi
(Ensures that services dependend on lanmanworkstation start correctly)

ONLY ON SQL SERVERS
sc.exe config mssqlserver depend= msiscsi
(ensures that SQL starts correctly upon reboot)

I'm not sure if these dependencies are ideal, or appropriate for your situation, but the lanmanserver command did resolve share availability issues for us. On the project I recently completed we configured about 20 iSCSI/NAS implementations with two or more attached servers (not my choice, by the way). The one caveat, and a VERY important one is to remember that if you make the server and workstation services dependent on iSCSI, and the server loses connectivity to the NAS (or other external storage) you will only be able to log on locally to the box. Also, the only way I know if to remove dependencies is through the registry (there may be a command for this, but I could not come up with it.)

I hope this is helpful! Feel free to email me if you would like input on any issues that arise. I certainly don't claim to be an expert but I have been fighting with issues around this for months!

Collapse -

More info

by sandm4n In reply to cannot access share

Today i tried to run \\servername\share on the actual server itself and it gave me the same error. Cannot access share .... you may not have permission.... cant read permissions from domain controller.

I have checked NTFS as well as shares and domain users plus admins have full access. I have also removed the server from the domain and then added it again.

I was having this same problem with another server a week back and had to rename the server to from slx-dgb to slxdgb. Removed it from network and added it again before it would work.

Now I could do the same thing with this one, but according to the company that maintains our Sage Line 500 which sits on this server, sage wont like the renaming of the server, hence why i haven't done it.

Any help would be much appriciated.

Collapse -

Try this..

by bart777 In reply to More info

Give the server a DNS alias. Then try to access the server by that name. You should get a duplicate name error.

If you do then make the following registry change.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameter?s


On the Edit menu, click Add Value, and then add the following
registry value:


Value name: DisableStrictNameChecking
Data type: REG_DWORD
Radix: Decimal
Value: 1

This is a way around the renaming of the server.

Best of luck.

Collapse -

same issue

by jhrltr In reply to cannot access share

I've been working on this issue for days googled it tech associates have been consulted , tryed microsoft online etc. no solution as of yet have you got answer yet

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums