General discussion

Locked

Cannot Change File Association

By Gregg S ·
I am running Windows XP Home Edition with Works installed on my PC. I want to change my file association for .rtf files to WordPad. However, the buttons to accept this change are grayed out. I am logged on as an Administrator. How do I solve this problem? Thanks!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by TxA In reply to Cannot Change File Associ ...

There are 2 most common ways to associate files to a program. I'm not sure which one you tried.

Here's the easiest way though:

Hold your left SHIFT button while right-clicking an .rtf file
With this, you'll get an extra option in the menu, called "Open with"
Select "Choose program" in the drop-down menu and then select Wordpad from the list.
Don't forget to check the checkbox "Always use this program to open this type of file" and click OK.

Try this and let know if you encounter any difficulties.

Kind regards,

David

Collapse -

by TheChas In reply to Cannot Change File Associ ...

You might have to go into the options / preferences menu in Works and release the file association for .rtf files there.

A lot of programs take over file associations and you need to release that programs hold on the file type before you can change the association to a different program.

In extreme cases, you may need to use regedit to change a file association.
I recommend NOT doing this unless you know your way around the registry very well. For file associations, there are multiple keys that need to be changed at the same time. Some of which use strings rather than clear text.

As always, should you decide to edit the registry, make sure that you have a backup copy and / or a restore point.

Chas

Collapse -

cannot change associations

by dcmarcus In reply to

i have tried the usual things to change associations, but they only work once and then revert - eg word documents show as text files. I think this started after an install of a new printer.
any help appreciated

Collapse -

Registry edit for XPpro SP2 (possibly other versions)

by 2btech In reply to cannot change association ...

I have encountered the same issue, and have made an adjustment in the registry to solve it.

It is a really good idea to back up the registry before you make any changes....That being said, what I am suggesting as a fix will change the ability for power or administrative users of your XP machine to modify the 'global' file associations.

1. As the local adminsitrator on your PC, Run 'regedit' tool and dial down to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
2. right-click on the NoFileAssociate key, and select modify
3. edit the "Value data:" field to 0 (zero)and select OK.
4. the NoFileAssociate entry should now be:
"NoFileAssociate" "REG_DWORD" "0x00000000(0)"
5. Close the registry editor tool
6. You may need to logoff and log back in to see the changes. Then modify your file associations through the GUI as per usual. Your edit options should no longer be grayed out.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums