General discussion

  • Creator
    Topic
  • #2257507

    Cannot delete folder and files from WinXP that were trasnferred from Win2K

    Locked

    by ddddddkkkkkkk ·

    A couple of years ago, I had a work laptop with Win2K Pro. I copied a folder from the laptop and moved it to my desktop at home…which is a WinXP Pro station. Now, I cannot even access the folder anymore, and I cannot delete it. It gives me Access is Denied. I have tried “SEVERAL” things!!! I have even gone into DOS and tried deleting it, and still I get “Access is Denied”???? I’m losing my head with MS Windows XP!!!!!!!!! Any thoughts?? Thanks!

All Comments

  • Author
    Replies
    • #3229502

      Use Knoppix

      by nicknielsen ·

      In reply to Cannot delete folder and files from WinXP that were trasnferred from Win2K

      Download it (http://www.knoppix.net/), burn it, boot to it, recover your files, delete the folder.

      I’ve never had a problem recovering data with Knoppix unless there was a corrupt directory entry or there was a pysical problem with the disk.

      Edited to add link

    • #3201763

      Never use NTFS

      by rlgoers ·

      In reply to Cannot delete folder and files from WinXP that were trasnferred from Win2K

      I’m sure the security “features” of NTFS are causing your headaches. As soon as I get a new computer, the first thing I do is reformat the drive with FAT32. That takes care of the problem for good.

      It’s not like someone’s going to steal all my data, and even if they did, NTFS wouldn’t stop a determined thief! As you have already found out; NTFS is more of a headache that a security feature.

    • #3201718

      It probably had permissions set

      by w2ktechman ·

      In reply to Cannot delete folder and files from WinXP that were trasnferred from Win2K

      for your old user account. Try changing the properties, or adding new permissions to the folder, then delete. If it does not work, you can log in as admin and try it.

    • #3230751

      I had the exact same problem

      by mark miller ·

      In reply to Cannot delete folder and files from WinXP that were trasnferred from Win2K

      I know what you’re talking about. I was used to using WinXP Home Edition, and I moved up to Professional Edition. I transferred over some folders I had burned to CD on my other (Home Edition) machine, and suddenly I couldn’t do a thing to them. I believe there’s an article in Windows Help about this. What’s probably going on is the system thinks you do not own the folder, since it has the same ownership information it had on your laptop. The issue is folder ownership. Try looking up “change folder ownership” in Windows Help. If you still can’t find it. Here’s what I remember I did to fix this.

      What I remember is you need to log in as Administrator, bring up Windows Explorer and go to Tools|Folder Options, and select the View tab. In the Advanced Settings list, deselect “Use simple file sharing”, hit OK.

      Now go back to Windows Explorer, and bring up the offending folder’s properties. There should be a new tab on the Properties dialog labeled “Security”. Select it. You will notice it brings up a list of all users who have access to it. What you need to do now is change the ownership of the folder.

      Click on the Advanced button. This will bring up a new dialog, called “Advanced Security Settings for “. Select the Owner tab. It will tell who the system thinks currently owns the folder. Type the name of the user ID that should own the folder into the textbox labeled “Current owner of this item:”, and select the “Replace owner on subcontainers and objects” checkbox. Then click OK. This will replace the ownership information on all files and subfolders under the folder you brought up properties on. Now click OK on the Properties dialog. Try accessing the folder and see if it works. If not, you need to go back into Properties for the folder (no need to go into the Advanced dialog this time) and add permissions for Administrator to access the folder. That should do it.

      It’s been a while since I’ve run into this problem, so I may have missed a couple details.

      I saw a post earlier suggesting that you not use NTFS. I recommend against using the likely alternative: FAT32. NTFS is a more secure filesystem to use. If you set up a limited account (non-Administrator), and use it for accessing the internet, coupled with NTFS, it makes your system MUCH more secure from malware.

      The reason for this is NTFS brings the permissions of each user account down to the file system level. In the default configuration of a limited account, all programs are prohibited from writing to the registry. With NTFS, all programs are also prohibited from writing to the system folders. FAT32 does NOT provide this protection.

      • #3201610

        Still a problem?

        by old-vms-dog ·

        In reply to I had the exact same problem

        What’s the status of your problem? Did Mark Miller’s response solve the problem for you or do you still need assistance? I have recently been working on a similar issue with
        Window’s XP Home edition and may have some additional info.

Viewing 3 reply threads