Question

Locked

Cannot get NAT to work as I would like with 2003 server

By Shippers ·
System configuration
====================

ISP
---
8 x IP addresses as supplied by ISP on subnet 255.255.252.0
Router configured in bridging mode (the only supported method with this particular ISP with multiple IP addresses)

2003 server
-----------
2 x network cards
1 with internal IP address of 192.168.1.11 on subnet 255.255.255.0
1 with external (ISP provided) IP address on subnet 255.255.252.0
NAT installed (Routing and remote access) but not operating correctly as yet.

There are also other 2003 servers as well with web applications, but this is not relevant.

Current (incorrect) situation
=============================

The workstations are using the IP addresses supplied by the ISP to enable web browsing. This, or course, eats up the 8 x ISP provided IP adresses, which is not acceptable.

If I configure the workstations to use an internal IP address (192.168.1.X on subnet 255.255.255.0), they ARE able to access resources (http, file access etc) supplied on one of the 8 ISP provided IP addresses. This tells me that NAT on the 2003 server is providing a gateway between the two subnets. HOWEVER, internet access is not provided. This appears to be more than a DNS problem, as if I find out the ip address of google (for example) and enter http://[ip address] into the web browser, I get the standard "page cannot be displayed" error message. I have also switched off the Routing and Remote Access firewall completely on the 2003 server, still with no success.

Requirement
===========

I would like all of the workstations to use internal IP addresses, with web browsing being enabled via NAT on the 2003 server through a single ISP provided IP address.


Thank you kindly in advance to anyone that can provide some assistance.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Now fixed

by Shippers In reply to Cannot get NAT to work as ...

It was a simple issue in the end - I needed to specify the ISP gateway address in the NIC on the server.

Collapse -

Try this out to see if it fixes your connection..

Fix your DNS problems
If you're having problems Web surfing, you may have a DNS problem. Here are quick ways to fix it.
DNS, though, can be your foe as well as your friend. DNS problems may stop you from being able to visit Web sites. If you're having problems connecting, it doesn't take much work to see if DNS is the cause, and if it is, to try to fix it.
To find out whether DNS is a potential culprit when you're having trouble connecting to a site, first ping the site to which you can't connect by issuing the ping command at the command prompt, like this:
ping www.computerworld.com
If the site is live, you'll get an answer like this
Pinging www.computerworld.com
[65.221.110.9 with 32 bytes of data:

Reply from 65.221.110.98: bytes=32
time=22ms TTL=235
Reply from 65.221.110.98: bytes=32
time=23ms TTL=235
Reply from 65.221.110.98: bytes=32
time=23ms TTL=235
Reply from 65.221.110.98: bytes=32
time=24ms TTL=235

Ping statistics for 65.221.110.98:
Packets: Sent = 4, Received = 4,
Lost = 0 (0% loss),
Approximate round trip times in
milli-seconds:
Minimum = 22ms, Maximum = 24ms,
Average = 23ms
If it's not, you'll get a response like this:
Ping request could not find host.
Please check the name and try again.
If you ping a site and it's live but you can't connect to it with your browser, a DNS problem might be the reason. If you suspect you're having a DNS problem, take the following actions:
Check your HOSTS file
If your HOSTS file contains an incorrect or outdated listing, you won't be able to connect. Even if you don't recall adding listings to a HOSTS file, it still might contain listings, because some Internet accelerator utilities edit them without telling you. Open your HOSTS file with Notepad and see if the site you can't connect to is listed there. If it is, delete the entry, and you should be able to connect.
For details about editing a HOSTS file, see "Hack DNS for lightning-fast Web browsing."
http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9019951
Check your DNS settings
Make sure your DNS settings are correct for your ISP or network. If you've changed your DNS settings to use a service such as OpenDNS, for example, you might have entered them incorrectly.
Find out from your ISP or network administrator what your DNS settings are supposed to be, or check the OpenDNS site (or another DNS service) for their server settings. Once you've done that, you'll need to make sure that you've entered the DNS settings properly.
Check the article "Hack DNS for lightning-fast Web browsing" for details about how to change your DNS settings. Then change the DNS servers to the proper ones, or choose "Obtain DNS server address automatically" if your ISP or network administrator tells you to use that setting.
Flush your DNS cache
The problem might be related to your DNS cache, so flush it out. To flush the cache, type ipconfig /flushdns at a command prompt.
Find out if your ISP is having DNS problems
Your ISP could be the source of the problem. One possibility is that one of its DNS servers is down and you're trying to access the downed server. If you know the addresses of the DNS servers, ping each of your ISP's DNS servers, and if any of them don't respond, remove them from your DNS list.
If you don't know the address of the DNS servers and you're supposed to use the choose "Obtain DNS server address automatically" setting, you'll have to call your ISP to see whether its DNS servers are having problems. Alternately, you can use the OpenDNS servers instead of your ISP's DNS servers. For details, see "Hack DNS for lightning-fast Web browsing."
http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9019951

Please post back if you have any more problems or questions.

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums