General discussion

Locked

Cannot log on to PC with cached profile

By adz666 ·
We are in the process of migrating to AD (Windows 2003), & have a problem with a small number of laptops (Windows XP SP1 & W2K SP4). After migrating the PC using the ADMT, the users are able to log onto the domain with their AD user ID. When the laptop is taken offline, they are still able to log on to their machine using their cached profile (not roaming). However, in a few cases, after having worked OK for a few days, the user will try to log on offline & receive a message saying that the domain is unavailable, & they cannot log on to their PC. This happens whether or not they have an active network connection (eg are connected to their home network). Logging on with the local admin ID, we can see that the local profile does still exist. After connecting to the network & logging on online, the problem goes away for a while. This is causing us major problems! Anybody have any suggestions? Thanks.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to Cannot log on to PC with ...

see if this is you: 842007 from support.microsoft.com
Microsoft Knowledge Base Article - 842007

Need More Help?
Contact a Support Professional by E-Mail, Online or Phone


Search Support (KB)
Windows Server 2003


Advanced Search and Help



Comments?
Provide us with feedback on this article

Support Centers
Windows Server 2003

Other Support Options
Contact Microsoft
Phone Numbers, Support Options and Pricing, Online Help, and more.

Customer Service
For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.

Newsgroups
Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.


Page Options
Send
Print


You experience synchronization problems if you do not disable the cache option for offline files on roaming user profile shares in Windows Server 2003
View products that this article applies to.
For a Microsoft Windows 2000 version of this article, see 287566.
SYMPTOMS
By using roaming user profiles in Microsoft Windows Server 2003, you may experience synchronization problems if you do not disable the cache option for offline files. The user profile may become unstable when both offline files and roaming user profiles try to synchronize the files in a user's profile.
CAUSE
This issue occurs because the cache option for offline files is based on the Server Message Block (SMB) protocol, and the cache option is SMB share-based.

Collapse -

by sgt_shultz In reply to

If the cache option is enabled on a shared folder, any files that are created on the remote shared folder from the local computer can be cached. However, this action may cause synchronization problems if one of the following conditions is true:
The cache option is enabled on a shared folder where roaming user profiles are located.
The cache option is enabled on a shared folder where roaming user profiles are accessed through a path where the cache option is enabled.
If a roaming user profile is located inside a shared folder where the cache option is enabled, offline files are cached in the user's profile as they are copied to and from the server. This functionality is designed to handle situations where programs work with new copies of a file and then rename the original file. (In other words, all files that are created on the remote shared folder from the local computer are cached.)

Because a roaming user profile can copy the files in the user's profile to temporary files on the server share and then rename these files, the files in the user's profile are added to the cache.

Collapse -

by sgt_shultz In reply to

WORKAROUND
To work around this issue, create a separate shared folder to store the user profiles, and then disable the cache option on that shared folder.

Notes
You can disable the cache option only on shared folders that are hosted by computers that run Windows Server 2003 or Microsoft Windows 2000 Server.
We recommend that you store the roaming user profiles and the offline-enabled shared folders on a separate server, whenever possible.
To disable the cache option by using the command line, follow these steps on the local computer where the shared folder resides:
Click Start, click Run, type CMD in the Open box, and then click OK.
At the command prompt, type net share sharename /cache:no, where sharename is the name of the shared folder.
To enable the cache option by using the command line, follow these steps on the local computer where the shared folder resides:
Click Start, click Run, type CMD in the Open box, and then click OK.
At the command prompt, type net share sharename/cache:yes, where sharename is the name of the shared folder.
To disable the cache option through the user interface, follow these steps:
Locate the shared folder by using Windows Explorer.
Right-click the folder, and then click Properties.
Click the Sharing tab, click Offline Settings, and then click Files or programs from the share will not be available offline.
STATUS
This behavior is by design.

Collapse -

by sgt_shultz In reply to

MORE INFORMATION
You must disable the cache option for offline files on shared folders where roaming user profiles are stored. If you want to store offline-enabled redirected folders and roaming user profiles on the same server, they must be in separate shared folders. For additional information about Microsoft IntelliMirror technologies, click the following article number to view the article in the Microsoft Knowledge Base:
818737 White paper: Technical overview of Windows Server 2003 Management Services

The information in this article applies to:
Microsoft Windows Server 2003, Enterprise Edition for the Workstation
Microsoft Windows Server 2003, Standard Edition

Collapse -

by adz666 In reply to

Thanks, but we're not using roaming profiles & most of the laptops in question are not using offline files.

Collapse -

by p.j.hutchison In reply to Cannot log on to PC with ...

I suggest creating local userids and login with those instead of using Cached Domain userids. The profile will be different but still usable. You can set NTFS permissions to allow access to files in their main domain profile.

Collapse -

by adz666 In reply to

Hmm, thanks, but I don't really want to start creating local IDs - have never had a problem with this under NT4, only with migrated AD users (& then only with a few - one of whom is the IS Infrastructure Manager, my boss, of course).

Collapse -

by rod In reply to Cannot log on to PC with ...

I am experiencing identical behavior with XP/SP2 and was wondering if you were able to resolve?

Collapse -

by muc_cn In reply to Cannot log on to PC with ...

I have the same problem in win2000!!have changed the profile, reset the account on server, still not working!!! Any idea about this??

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums