General discussion

Locked

Cannot Open the File: Mk:@MSITStore:C....

By perk ·
I have recently had the dubious pleasure to see the above mentioned message anytime I tried to open any .CHM files on my system. My system is running Windows XP Home SP2. (Yeah, I know, I'd better use Professional, but this one was pre-installed when I bought the system, and I couldn't afford to upgrade.)

The problem appeared when I was about to read an E-book in .CHM format. I tried to solve it by looking in the Help file system, but it wouldn't open... About this time I understood that it was not just a matter of a corrupt file, any .CHM I tried refused to open, no matter if it was residing on the local file system or on the Local Network. I tried to open some common applications and their help files, all with the same result.

Now I knew that the problem was in the system and not related to just a few files, so I turned my attention to the Microsoft Technet, Knowledge Base and Support Center Web sites. I found an article (http://support.microsoft.com/default.aspx?scid=kb;en-us;312456) that had an apt description of the problem. Too bad though, it was only applying to Windows 98 systems... The rest of the articles discussed the unintentional implications of service pack installations (896358, 840315), and only applying to opening .CHM files with MSIE...

I found the solution in a very cryptic instruction in a Forum.

Open a CMD window, type the following on the command line:

regsvr32 %systemroot%\system32\hhctrl.ocx <press enter>
regsvr32 %systemroot%\system32\itss.dll <press enter>

You will receive a success message after each of these commands.

I do not know when it first appeared, nor do I know what caused it (and I don't really care, I'm just very pleased with having found a solution that works for me).

NOTE:
I have not had this problem on any other systems, so I do not know if it applies to anything but XP.

This conversation is currently closed to new comments.

20 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Finally..an answer

by sydney In reply to Cannot Open the File: Mk: ...

I have to thank you...I have spent the last two days looking at a LOT of useless information about this problem. Your post finally gave me the solution. So, again...thank you for your time in posting the only solution I have been able to find, on the internet, or in talking to people who are supposed to know. PERFECT!
Sydney Ann

Collapse -

But hhctrl.ocx won't replace!

by ryanbehrman In reply to Cannot Open the File: Mk: ...

As soon as I delete hhctrl.ocx or try replace it, it replaces itself with the original version I deleted! So I'm stuck. Anyone else have this problem and know the fix? Thanks!

Collapse -

copy hhctrl.ocx from another computer and replace it and register

by alexzhuu In reply to But hhctrl.ocx won't repl ...

http://bubble.ro/Cannot_Open_the_File__Mk__MSITStore___Error_Message.html

Collapse -

Thank you!

by mrducky In reply to Cannot Open the File: Mk: ...

I read all the microsoft support stuff too, it didn't work. I finally found your note about registering itss.dll, and it worked. Thank you very much.

Collapse -

you are very welcome

by alexzhuu In reply to Thank you!

you are very welcome

Collapse -

Solved problem

by nguyentuan71vn In reply to Cannot Open the File: Mk: ...

Thank for your instruction. My problem is solved. Thank you so much.

Collapse -

Your the MAN

by steve In reply to Cannot Open the File: Mk: ...

This fix works like a charm ... GREAT ADVICE

Collapse -

I am so thankful

by chaosad In reply to Cannot Open the File: Mk: ...

I am so thankful that I managed to find your post after a lot of searching through trash even micro$oft's own site gave me no clues. Thank you for this

Collapse -

W2K and XP-Prof also

by qwerty2004qwertz In reply to Cannot Open the File: Mk: ...

Oh, man, you made my day !!!

I searched for hours and nobody could say that one needs to reregister also the idss.dll file. How could this be possible? How they didn't know or omitted to say?

Anyway, congratulations. Your trick works both on Win2000 and WinXP Proffesional.

One question: how did you figure it out that itss.dll also needs reregistering?

Collapse -

itircl.dll also may need to refresh registration

by qwerty2004qwertz In reply to Cannot Open the File: Mk: ...

I found an article about this problem.

http://www.robworley.com/index.php?title=windows_blows&more=1&c=1&tb=1&pb=1

It gives a link to a tool that makes the same as you described above, but it says also about another file named itircl.dll that needs to be refreshed.

http://helpware.net/downloads/index.htm#MJs

I ran it and it tells some interesting details.

Anyway, you are the hero, cause you solved my problem.

Back to Windows Forum
20 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums