General discussion

Locked

Cannot Rename Folders without the delete permissions

By clarke ·
Can someone PLEASE help me? I have tried desperately to find a solution to my problem.
My problem is as follows:

When you right click in an explorer window and goto New -> Folder, windows creates
a folder called "New Folder" instead of asking you what you want the folder to be
called before creating it. So if you don't have the delete, delete subfolders and
files, permissions you can only create new folders called "New Folder". This is
highly annoying because I want users to be able to create new folders and files in
explorer but not delete them after.

Does anyone have any Ideas as to how I can right click in explorer and create a new
folder or file without windows calling it New Folder first?????

Cheers,

Richie

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Possible help

by marianhorsley In reply to Cannot Rename Folders wit ...

I am using Win XP as an operating system.I was looking for the same answer when I realized that after having done a system restore My documents icon showing under the Desktop in Explorer wasn't consistant with My Documents under Documents and Settings (my name). During the system restore it moved many of my files to a place called My Recent Documents. It doesn't have an icon that looks like a folder, but that is essentially a folder. The path is C:/Documents & Settings/Marian/My Documents. It took some time for me to realize that is where all my lost info was. Once I placed everything back where it belonged and both the My Document folders were reflecting the identical files, the ability was returned to rename files and folders.

Please let me know if this helps you. I am a computer mentor in a retirement community. It will verify what I think I did.

Marian

Collapse -

Two things

by stress junkie In reply to Cannot Rename Folders wit ...

When you create a new folder in Explorer the default
name is, in fact, New Folder. However, if you look at
the folder you will see that the name is highlighted.
You can press the backspace key to clear the line and
then type in whatever name you please.

Existing folder names can be fixed by positioning the
mouse cursor on one of the folders named 'New Folder'
and pressing the right hand button. You will see a
menu. Select 'Properties'. You will see the properties
displayed. Change the permissions to allow the folder
to be deleted. Press the 'OK' button. Now the folder can
be renamed or deleted.

The second part above may not work if the folders are
on a network share 'drive'. If those instructions don't
work and if this is in a business environment then see
your system administrator about checking the
permissions on the network share.

Collapse -

Blast from the past!

by mgordon In reply to Cannot Rename Folders wit ...

If you don't mind something a bit "retro", use the command shell. Start -> Run -> "CMD" and hit enter. This gives you a command prompt or command line (shell, "DOS" prompt, etc). Navigate to the directory (folder) in which you want to create the new one, and enter: mkdir <yourname> where <yourname> is the preferred name of the new directory (folder). Beware embedded spaces; command line programs do not like them because spaces separate the parts of a command. If you must have spaces, use quotes (and no, there is no such thing as "single quote" and "double quote", there are only "quotes" and 'apostrophes').

mkdir "my folder with embedded spaces" will do the trick.

Back to Security Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums