cannot send external email to public folder

By markbagus ·
I have a public folder problem with a client running SBS 2003. I have recently taken over maintenance of the network - after they parted company with their previous chap.

We have a distrubution group SALES1 and one of its email addresses is SALES@

This group has, in its members, the public folder SALESEMAILS.

Basically we want all emails sent to sales@ to end up in this public folder. Not normally a problem !

The strange thing is when anyone sends an email to sales@ from their user account within the company, it will find its way to the public folder fine.

However, when anyone emails from outside the company to sales@, they get a returned message saying:

Delivery to the following recipients failed.


Other emails sent outside the company to people within the organisation find their way to the individuals exchange mailbox fine.

I guess there is a problem moving the email internally to the salesemails public folder ??

Hope someone can help me with any advice on this problem.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

This might help you...

Please post back if you have any more problems or questions.

Collapse -

The first thing I would do is see if I can replicate

by Dumphrey In reply to cannot send external emai ...

the problem. Create another mail enabled public folder and see if you can send mail to it from outside the agency.
Next check membership and addresses, make sure that the data you expect for the public folder is in fact there (though i'm am positive you have done this at least twice by now =)).
But look over the properties of the folder is exchange sysadmin panel (well the SBS version of..)
Do you get any further detail on the NDR for the folder? Anything in event viewer?

Collapse -

problem sorted - thanks for your help :-)

by markbagus In reply to cannot send external emai ...

Got it sorted. Problem was permissions on the public folder.

I had given the distribution group, and the default group contributor permissions (hence internal email working fine) - but the permissions for anonymous were set to none - which was wrong. I set the anonymous permissions to contributor and in flowed some junk email - but at least it works now.

It seems internal email uses default, but external email uses anonymous - which in hindsight would make sense given external email could come from anyone/anywhere.

Anyway, the problem is sorted out. Thanks for your help and all the best.


Collapse -

No problem. We are always here to help. :)

Please post back if you have any more problems or questions.

Related Discussions

Related Forums