Cannot send message to MSMQ from SQL Server

By jonathan.freeman ·
Civica Authority Financials application database (RadiusFinancials on Polysrv2, running 32 bit SQL Server 2000 Enterprise and 64 bit Win 2003) executes stored procedure to pass a message to the private message queue [reportq] on the application server (CX10).

SP_SEND_REPORT_MESSAGE uses the sp_OACreate stored procedure in the master database to create an instance of ReportMessage.dll (this is saved to C:\Authority Financials on the SQL Server).

EXECUTE @int_result = sp_OACreate 'ReportMessage.CReportMSMQ', @int_msmqqueue OUT, 1

It then uses the sp_OAMethod stored procedure to send a message to the message queue on the application server.

EXECUTE @int_result = sp_OAMethod @int_msmqqueue, 'Send', NULL, @nJobNumber, @bRunNow, @bMajorJob, @MSMQPath

This is failing with SQL error 60105, severity 16, state 1 (application event id 17052 source MSSQL).

This was working fine on our previous SQL Server which was SQL Server 2000 Enterprise on Win2K Server.

DLL is same on both SQL boxes, SQLServer and SQLAgent both running under same account.

Has anyone got any ideas? I am really struggling with this.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

When Security Hurts: Win2K3 throws a couple of curveballs at MSMQ

by robo_dev In reply to Cannot send message to MS ...

For added security, many things are locked down tighter in Win2K3, especially COM and DCOM stuff.

One fix may be to change the queue type to non-transactional and in server security acceptence for the reviever form 2003 server.

Also, if MSMQ was installed in Active Directory mode on 2K and it's in workgroup mode in 2K3, the path names for remote systems will not be correct.

What are the actual permissions on the queue? One easy test is to add
full control for Everyone and Anonymous Logon - basically disabling queue
level security - to see if messages then get delivered.

Never overlook something as simple as incorrect trust settings:

Check the Windows firewall is opening ports for MQSVC.EXE.

msft google groups chatter:

Related Discussions

Related Forums